summaryrefslogtreecommitdiff
path: root/packages/udev/udev_097.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-11-07 12:02:31 +0000
committerMatthias Hentges <oe@hentges.net>2006-11-07 12:02:31 +0000
commit3b7d18f95dbaaca9faa1ffcc9a780431e7351902 (patch)
treee1c739a8399ba2e9f9b76ffbace59b2c58b63f79 /packages/udev/udev_097.bb
parentb2b8e8ebef369da9281fea67b2c0c7e57d48f6e4 (diff)
udev: Auto-add the rootfs partition to mount.blacklist via postinst to work around a bug in the auto-mounter * * Untested in .dev! * *
Diffstat (limited to 'packages/udev/udev_097.bb')
-rw-r--r--packages/udev/udev_097.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/packages/udev/udev_097.bb b/packages/udev/udev_097.bb
index 3abd9b5fa7..497357775e 100644
--- a/packages/udev/udev_097.bb
+++ b/packages/udev/udev_097.bb
@@ -8,7 +8,7 @@ used to detect the type of a file system and read its metadata."
DESCRIPTION_libvolume-id-dev = "libvolume_id development headers, \
needed to link programs with libvolume_id."
-PR = "r3"
+PR = "r4"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -61,3 +61,21 @@ do_install () {
do_install_append_h2200() {
install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
}
+
+pkg_postinst_append() {
+
+ # Add the root partition to mount.blacklist to avoid a bug in the auto-mounter,
+ # causing confusion with fsck on boot
+
+ while read dev mp fs junk
+ do
+ if test "$mp" = "/"
+ then
+ root_partition="$dev"
+ echo "$root_partition" >> /etc/udev/mount.blacklist
+ fi
+ done < /etc/fstab
+
+}
+
+