summaryrefslogtreecommitdiff
path: root/packages/udev/udev_092.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2006-11-13 18:57:30 +0000
committerCliff Brake <cbrake@bec-systems.com>2006-11-13 18:57:30 +0000
commit40951de5f883d7a2d9d5445a9b73c3424ee245f1 (patch)
tree6a9d8dfe2fef258e9dd8b079c3517b0c1edbfbe6 /packages/udev/udev_092.bb
parent1c9e8b7ced097812f43cdd5782023464cef09ed8 (diff)
parente2e9b0ab1d6af8ec246cef0f9d848083dff2b8e0 (diff)
merge of '9ebe19c38b13611632684c440b048e45471bf916'
and 'e0d42dfa54011bb501a5a723ec0554c757bfc933'
Diffstat (limited to 'packages/udev/udev_092.bb')
-rw-r--r--packages/udev/udev_092.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
index 2de59fb018..3d33938fb1 100644
--- a/packages/udev/udev_092.bb
+++ b/packages/udev/udev_092.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES = "hotplug"
-PR = "r12"
+PR = "r13"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -57,3 +57,20 @@ do_install () {
do_install_append_h2200() {
install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
}
+
+pkg_postinst_append() {
+
+ # Add the root partition to mount.blacklist to avoid a bug in the auto-mounter,
+ # causing confusion with fsck on boot
+
+ while read dev mp fs junk
+ do
+ if test "$mp" = "/"
+ then
+ root_partition="$dev"
+ echo "$root_partition" >> /etc/udev/mount.blacklist
+ fi
+ done < /etc/fstab
+
+}
+