summaryrefslogtreecommitdiff
path: root/packages/udev/udev_065.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-08 16:58:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-08 16:58:17 +0000
commit1363b0b7be175125f2e62ecff97ed87b79bfabb2 (patch)
tree2ed455169a31955a980d02e80b58528069182355 /packages/udev/udev_065.bb
parentf0b70c2b466aac9bcf1026f87ec3baf7e7dc0c5e (diff)
add udev-065
Diffstat (limited to 'packages/udev/udev_065.bb')
-rw-r--r--packages/udev/udev_065.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/udev/udev_065.bb b/packages/udev/udev_065.bb
new file mode 100644
index 0000000000..f6a2783136
--- /dev/null
+++ b/packages/udev/udev_065.bb
@@ -0,0 +1,22 @@
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
+ file://tmpfs.patch;patch=1 \
+ file://noasmlinkage.patch;patch=1 \
+ file://flags.patch;patch=1 \
+ file://tty-symlinks.patch;patch=1 \
+ file://init"
+
+include udev.inc
+
+PR = "r0"
+UDEV_EXTRAS = "extras/scsi_id/ extras/volume_id/ extras/run_directory/"
+
+#FIXME UDEV MIGRATION PLAN:
+#FIXME a) udevd is now a netlink daemon and needs to be started by the init script (ours is way too old)
+#FIXME b) sbin/hotplug should no longer be called by the kernel, i.e. echo "" >/proc/sys/kernel/hotplug
+#FIXME done c) until d) happens, udev will emulate hotplugd behaviour (see do_install_append()
+#FIXME d) eventually hotplug should no longer be used at all, all agents shall be converted to udev rules
+
+do_install_append() {
+ install -m 0755 extras/run_directory/udev_run_hotplugd ${D}${sbindir}/
+ echo RUN+="/sbin/udev_run_hotplugd" >>${D}${sysconfdir}/udev/rules.d/50-udev.rules
+}