summaryrefslogtreecommitdiff
path: root/packages/udev/udev-100/flags.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-09-12 09:25:38 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-09-12 09:25:38 +0000
commit30136a8e89b86b9e3d0fa4b07fafdf484ff8d4f2 (patch)
treefda5c2385c803bfdf3e338b3368c7d14622e41c4 /packages/udev/udev-100/flags.patch
parent431b0378e7c2a282c4dc5ba2bf641d644facc4dd (diff)
parent1849c7146319438853e3b6c932003bde1a14b32f (diff)
merge of '14cc680dbaa6317eec602330d2fe0ac7dea3be7a'
and '350557edbea2aa55107ce4c0e4dffc849b7e2307'
Diffstat (limited to 'packages/udev/udev-100/flags.patch')
-rw-r--r--packages/udev/udev-100/flags.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/udev/udev-100/flags.patch b/packages/udev/udev-100/flags.patch
new file mode 100644
index 0000000000..492a39881c
--- /dev/null
+++ b/packages/udev/udev-100/flags.patch
@@ -0,0 +1,51 @@
+--- udev-089/Makefile.orig 2006-04-08 13:32:53.000000000 +0200
++++ udev-089/Makefile 2006-04-08 13:34:27.000000000 +0200
+@@ -117,28 +117,28 @@
+ AR = $(CROSS_COMPILE)ar
+ RANLIB = $(CROSS_COMPILE)ranlib
+
+-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS += $(WARNINGS)
++override CFLAGS += $(WARNINGS)
+
+ LDFLAGS = -Wl,-warn-common
+
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -DDEBUG
++ override CFLAGS += -DDEBUG
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS += -fprofile-arcs
+ endif
+
+@@ -151,11 +151,11 @@
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+