summaryrefslogtreecommitdiff
path: root/packages/uboot/u-boot-1.2.0
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2007-12-17 06:05:26 +0000
committerAndrew Wilcox <andy@protium.com>2007-12-17 06:05:26 +0000
commit5206b0d92ce6a6622ec041231314d7242a35f0e8 (patch)
tree94edc2ae7c369c2c6fe5a831d68ba3c6ebc60de6 /packages/uboot/u-boot-1.2.0
parent2eef78ec91e7fc70a5ccc318e78f43d55d44b8b2 (diff)
Rename uboot-utils to u-boot-utils-native. u-boot-utils now makes
target u-boot utility fw_setenv for one distro.
Diffstat (limited to 'packages/uboot/u-boot-1.2.0')
-rw-r--r--packages/uboot/u-boot-1.2.0/env-Makefile.patch29
1 files changed, 12 insertions, 17 deletions
diff --git a/packages/uboot/u-boot-1.2.0/env-Makefile.patch b/packages/uboot/u-boot-1.2.0/env-Makefile.patch
index ad3a6b39a3..f6e9cb39ae 100644
--- a/packages/uboot/u-boot-1.2.0/env-Makefile.patch
+++ b/packages/uboot/u-boot-1.2.0/env-Makefile.patch
@@ -1,24 +1,19 @@
---- u-boot-1.1.2.orig/tools/env/Makefile 2003-06-27 14:32:48.000000000 -0700
-+++ u-boot-1.1.2/tools/env/Makefile 2006-11-08 12:33:43.000000000 -0800
-@@ -27,7 +27,7 @@
- all: fw_printenv
+--- u-boot-1.2.0/tools/env/Makefile.orig 2007-12-12 12:52:51.508745236 -0800
++++ u-boot-1.2.0/tools/env/Makefile 2007-12-12 12:54:09.997218038 -0800
+@@ -31,7 +31,7 @@
+ all: $(obj)fw_printenv
- fw_printenv: $(SOURCES) $(HEADERS)
-- $(CROSS_COMPILE)gcc -Wall -DUSE_HOSTCC $(SOURCES) -o fw_printenv
-+ $(CROSS_COMPILE)gcc $(TARGET_CFLAGS) -idirafter ../../include -Wall -DUSE_HOSTCC $(SOURCES) -o fw_printenv
+ $(obj)fw_printenv: $(SRCS) $(HEADERS)
+- $(CROSS_COMPILE)gcc $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
++ $(CROSS_COMPILE)gcc $(TARGET_CFLAGS) -idirafter ../../include -DUSE_HOSTCC $(SRCS) -o $(obj)fw_printenv
clean:
- rm -f fw_printenv crc32.c
-@@ -37,9 +37,9 @@
+ rm -f $(obj)fw_printenv $(obj)crc32.c
+@@ -43,6 +43,6 @@
- #########################################################################
-
--.depend: Makefile $(SOURCES)
-- $(CC) -M $(HOST_CFLAGS) $(CPPFLAGS) -DUSE_HOSTCC $(SOURCES) > $@
-+#.depend: Makefile $(SOURCES)
-+# $(CC) -M $(HOST_CFLAGS) $(TARGET_CPPFLAGS) -DUSE_HOSTCC $(SOURCES) > $@
+ include $(TOPDIR)/rules.mk
--sinclude .depend
-+#sinclude .depend
+-sinclude $(obj).depend
++#sinclude $(obj).depend
#########################################################################