summaryrefslogtreecommitdiff
path: root/packages/uboot-utils/tools-Makefile.patch
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2006-12-07 19:40:25 +0000
committerAndrew Wilcox <andy@protium.com>2006-12-07 19:40:25 +0000
commit0165cbef046ef6a02bf096806f2e72d3785358a5 (patch)
tree6f99f4e9035a5dcecfc17c6654ef03e44d0a7b0a /packages/uboot-utils/tools-Makefile.patch
parentaa5a787f25f567632f53decbaee305315e6d1c58 (diff)
uboot: OS native utils for accessing the boot environment vars.
Diffstat (limited to 'packages/uboot-utils/tools-Makefile.patch')
-rw-r--r--packages/uboot-utils/tools-Makefile.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/uboot-utils/tools-Makefile.patch b/packages/uboot-utils/tools-Makefile.patch
new file mode 100644
index 0000000000..a44bc917d6
--- /dev/null
+++ b/packages/uboot-utils/tools-Makefile.patch
@@ -0,0 +1,19 @@
+--- u-boot-1.1.2.orig/tools/Makefile 2004-09-28 14:39:46.000000000 -0700
++++ u-boot-1.1.2/tools/Makefile 2006-11-08 11:07:18.000000000 -0800
+@@ -56,7 +56,7 @@
+ HOSTOS := $(shell uname -s | tr A-Z a-z | \
+ sed -e 's/\(cygwin\).*/cygwin/')
+
+-TOOLSUBDIRS =
++TOOLSUBDIRS = env
+
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific. It
+@@ -176,6 +176,7 @@
+ else
+ @for dir in $(TOOLSUBDIRS) ; do \
+ $(MAKE) \
++ CROSS_COMPILE=$(CROSS_COMPILE) \
+ HOSTOS=$(HOSTOS) \
+ HOSTARCH=$(HOSTARCH) \
+ HOST_CFLAGS="$(HOST_CFLAGS)" \