summaryrefslogtreecommitdiff
path: root/packages/uboot-utils/env-Makefile.patch
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2006-12-07 19:40:25 +0000
committerAndrew Wilcox <andy@protium.com>2006-12-07 19:40:25 +0000
commit0165cbef046ef6a02bf096806f2e72d3785358a5 (patch)
tree6f99f4e9035a5dcecfc17c6654ef03e44d0a7b0a /packages/uboot-utils/env-Makefile.patch
parentaa5a787f25f567632f53decbaee305315e6d1c58 (diff)
uboot: OS native utils for accessing the boot environment vars.
Diffstat (limited to 'packages/uboot-utils/env-Makefile.patch')
-rw-r--r--packages/uboot-utils/env-Makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/uboot-utils/env-Makefile.patch b/packages/uboot-utils/env-Makefile.patch
new file mode 100644
index 0000000000..ad3a6b39a3
--- /dev/null
+++ b/packages/uboot-utils/env-Makefile.patch
@@ -0,0 +1,24 @@
+--- u-boot-1.1.2.orig/tools/env/Makefile 2003-06-27 14:32:48.000000000 -0700
++++ u-boot-1.1.2/tools/env/Makefile 2006-11-08 12:33:43.000000000 -0800
+@@ -27,7 +27,7 @@
+ all: fw_printenv
+
+ fw_printenv: $(SOURCES) $(HEADERS)
+- $(CROSS_COMPILE)gcc -Wall -DUSE_HOSTCC $(SOURCES) -o fw_printenv
++ $(CROSS_COMPILE)gcc $(TARGET_CFLAGS) -idirafter ../../include -Wall -DUSE_HOSTCC $(SOURCES) -o fw_printenv
+
+ clean:
+ rm -f fw_printenv crc32.c
+@@ -37,9 +37,9 @@
+
+ #########################################################################
+
+-.depend: Makefile $(SOURCES)
+- $(CC) -M $(HOST_CFLAGS) $(CPPFLAGS) -DUSE_HOSTCC $(SOURCES) > $@
++#.depend: Makefile $(SOURCES)
++# $(CC) -M $(HOST_CFLAGS) $(TARGET_CPPFLAGS) -DUSE_HOSTCC $(SOURCES) > $@
+
+-sinclude .depend
++#sinclude .depend
+
+ #########################################################################