summaryrefslogtreecommitdiff
path: root/packages/u2nl/files/buildsystem.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:50:04 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:50:04 +0000
commita29979e19ed76c2029cfd822951b7fde56a98a8e (patch)
tree85102cf43b72d5ce2294ab17f565183b4436729d /packages/u2nl/files/buildsystem.patch
parent16b15891b993ca44dacd6c15ec678b2eac721548 (diff)
parent302f1878f6adacd506a24dd55fecc262a57bf61e (diff)
merge of '1d2340f5c0766711d217ca40fbfcb4cb196412ac'
and '8bee8c12a8f566036b80dc740f5215782a19eb8b'
Diffstat (limited to 'packages/u2nl/files/buildsystem.patch')
-rw-r--r--packages/u2nl/files/buildsystem.patch18
1 files changed, 8 insertions, 10 deletions
diff --git a/packages/u2nl/files/buildsystem.patch b/packages/u2nl/files/buildsystem.patch
index 2877a01729..9de58fa435 100644
--- a/packages/u2nl/files/buildsystem.patch
+++ b/packages/u2nl/files/buildsystem.patch
@@ -1,8 +1,8 @@
-Index: u2nl-1.1/Makefile
+Index: u2nl-1.3/Makefile
===================================================================
---- u2nl-1.1.orig/Makefile 2005-03-06 16:32:23.000000000 -0500
-+++ u2nl-1.1/Makefile 2005-03-11 02:38:00.454572600 -0500
-@@ -1,10 +1,25 @@
+--- u2nl-1.3.orig/Makefile 2005-01-03 19:31:20.000000000 +0100
++++ u2nl-1.3/Makefile 2006-12-14 12:38:15.052227000 +0100
+@@ -1,5 +1,25 @@
+CC = gcc
+CFLAGS = -Wall -g
+LDFLAGS =
@@ -17,18 +17,16 @@ Index: u2nl-1.1/Makefile
all: u2nl
u2nl: u2nl.c
-- gcc $(CFLAGS) -Wall -g u2nl.c -o u2nl
+- gcc -Wall -g u2nl.c -o u2nl
-
+ $(CC) $(CFLAGS) $(LDFLAGS) u2nl.c -o u2nl
+
- install:
-- cp u2nl /usr/local/bin
++install:
+ $(INSTALL_DIR) $(DESTDIR)$(bindir)
+ $(INSTALL_BIN) u2nl $(DESTDIR)$(bindir)/u2nl
+
+uninstall:
+ -rm -f $(DESTDIR)$(bindir)/u2nl
-
- clean:
-- rm -fR u2nl
++
++clean:
+ -rm -fR u2nl