summaryrefslogtreecommitdiff
path: root/packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2008-12-09 17:05:48 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2008-12-09 17:05:48 +0100
commitf44cdf94ca6022fa4238b541dfa0d4bac993607c (patch)
tree476a1235a00a199ea742fe9c72732fe335929d04 /packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch
parenta72c5b3bfce8525fda73a0b87008c83e309d825e (diff)
u-boot: drop obsolete patches for boc01
Diffstat (limited to 'packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch')
-rw-r--r--packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch128
1 files changed, 0 insertions, 128 deletions
diff --git a/packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch b/packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch
deleted file mode 100644
index 529a442321..0000000000
--- a/packages/u-boot/u-boot-1.3.2/boc01/009_03_u-boot-1.3.2_Extender_IO.patch
+++ /dev/null
@@ -1,128 +0,0 @@
-Index: u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c
-===================================================================
---- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/mpc8313erdb.c 2008-11-21 15:30:25.000000000 +0100
-+++ u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c 2008-11-21 15:40:06.000000000 +0100
-@@ -40,10 +40,20 @@
- if (im->pmc.pmccr1 & PMCCR1_POWER_OFF)
- gd->flags |= GD_FLG_SILENT;
- #endif
--
- return 0;
- }
-
-+int misc_init_f(void)
-+{
-+#ifdef INIT_EXIO
-+ ulong addr;
-+ puts("EXIO: ready\n");
-+ addr = ADDR_EXIO;
-+ *((u_char *)addr) = INIT_EXIO;
-+
-+#endif
-+}
-+
- int checkboard(void)
- {
- puts("Board: Freescale MPC8313ERDB\n");
-Index: u-boot-1.3.2/common/cmd_exio.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ u-boot-1.3.2/common/cmd_exio.c 2008-11-21 15:40:06.000000000 +0100
-@@ -0,0 +1,59 @@
-+/*
-+ * (C) Copyright 2008
-+ * Alexandre Coffignal, CenoSYS, alexandre.coffignal@cenosys.com
-+ *
-+ * See file CREDITS for list of people who contributed to this
-+ * project.
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License as
-+ * published by the Free Software Foundation; either version 2 of
-+ * the License, or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston,
-+ * MA 02111-1307 USA
-+ */
-+
-+
-+#include <common.h>
-+#include <config.h>
-+#include <command.h>
-+extern void init_exio(char value);
-+
-+int do_exio (cmd_tbl_t * cmdtp, int flag, int argc, char *argv[])
-+{
-+
-+ unsigned char ucExio;
-+ ulong addr;
-+ if (argc < 2)
-+ goto usage;
-+
-+ ucExio = simple_strtoul (argv[1], NULL, 10);
-+
-+ addr = ADDR_EXIO;
-+ *((u_char *)addr) = ucExio;
-+
-+ printf("%s 0x%2x\n",argv[0],ucExio);
-+
-+ return 0;
-+
-+usage :
-+ printf ("Usage:\n%s\n", cmdtp->usage);
-+ return 1;
-+} /* do_gpio() */
-+
-+/***************************************************/
-+
-+U_BOOT_CMD(
-+ exio, 2, 1, do_exio,
-+ "exio - Extender io Output\n",
-+ " - Set or clear extender io Output.\n"
-+ "exio value - \n"
-+);
-Index: u-boot-1.3.2/common/Makefile
-===================================================================
---- u-boot-1.3.2.orig/common/Makefile 2008-11-21 15:35:49.000000000 +0100
-+++ u-boot-1.3.2/common/Makefile 2008-11-21 15:40:06.000000000 +0100
-@@ -52,6 +52,7 @@
- COBJS-$(CONFIG_CMD_DTT) += cmd_dtt.o
- COBJS-$(CONFIG_CMD_CAPSENSE) += cmd_capsense.o
- COBJS-$(CONFIG_CMD_GPIO) += cmd_gpio.o
-+COBJS-$(CONFIG_CMD_EXIO) += cmd_exio.o
- COBJS-y += cmd_eeprom.o
- COBJS-$(CONFIG_CMD_ELF) += cmd_elf.o
- COBJS-$(CONFIG_CMD_EXT2) += cmd_ext2.o
-Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
-===================================================================
---- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-21 15:38:44.000000000 +0100
-+++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-21 15:40:06.000000000 +0100
-@@ -49,6 +49,7 @@
- #define CONFIG_SYS_CLK_FREQ CONFIG_83XX_CLKIN
-
- #define CONFIG_BOARD_EARLY_INIT_F /* call board_pre_init */
-+#define CONFIG_MISC_INIT_F
-
- #define CFG_IMMR 0xE0000000
-
-@@ -372,6 +373,13 @@
- #define CONFIG_CMD_NAND
- #define CONFIG_CMD_SPI
- #define CONFIG_CMD_GPIO
-+#define CONFIG_CMD_EXIO
-+
-+
-+/*Extender io*/
-+#define ADDR_EXIO 0xFA000000
-+#define INIT_EXIO 0x59
-+
-
- #if defined(CFG_RAMBOOT)
- #undef CONFIG_CMD_ENV