summaryrefslogtreecommitdiff
path: root/packages/totem/files/cflags.patch
diff options
context:
space:
mode:
authorFrederic Bompart <frederic@unknown.openembedded.org>2005-09-20 07:18:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-20 07:18:17 +0000
commitdd088063c0542a8940f201b33ae6ce904198d9ea (patch)
tree9095d086f6cb03c4db531ad6941f5b5cc61ff937 /packages/totem/files/cflags.patch
parent00dc4d090496ec5391685e5c316b08c05c93448b (diff)
totem: version 1.0.2 now compiles
I removed version 0.101 which was marked as broken. A few fixes were needed to disable gnomeui code in totem-1.0.2. Don't even try to upgrade it to version 1.2.x for now: it has even more dependencies, such as a very recent version of gnome-vfs...
Diffstat (limited to 'packages/totem/files/cflags.patch')
-rw-r--r--packages/totem/files/cflags.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/totem/files/cflags.patch b/packages/totem/files/cflags.patch
new file mode 100644
index 0000000000..a03247332f
--- /dev/null
+++ b/packages/totem/files/cflags.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/Makefile.am~cflags
++++ totem-1.0.4/src/Makefile.am
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = bvw-test list_v4l test-parser disc-test metadata-test
++#noinst_PROGRAMS = bvw-test list_v4l test-parser disc-test metadata-test
+
+ if TOTEM_VANITY
+ VANITY=vanity
+@@ -179,8 +179,10 @@
+ list_v4l_SOURCES = list_v4l.c $(BACON_V4L_SELECTION)
+ list_v4l_LDADD = $(GTK_LIBS)
+
++test_parser_CFLAGS = $(TOTEM_PLPARSER_CFLAGS)
+ test_parser_SOURCES = test-parser.c
+ test_parser_LDADD = \
++ $(TOTEM_PLPARSER_LIBS)
+ $(EXTRA_GNOME_LIBS) \
+ libtotem-plparser.la
+
+@@ -224,6 +226,8 @@
+ totem-disc.h \
+ totem-pl-parser.h
+
++libtotem_plparser_la_CFLAGS = $(TOTEM_PLPARSER_CFLAGS)
++
+ libtotem_plparser_la_LDFLAGS = \
+ -version-info $(PLPARSER_LT_VERSION) \
+ -no-undefined \