summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:47:00 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:47:00 +0000
commit16b15891b993ca44dacd6c15ec678b2eac721548 (patch)
tree22fcb57666e6705c5a636349fc6e6939799576c9 /packages/tasks
parent44fd0a5b1ae5367de691e3437ae9832d800c22e7 (diff)
task-self-hosting: Metapackage to install everything needed for self hosted builds
Tested with Angstrom-2007.1/i686 build in chroot - bitbake nano finished.
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-self-hosting.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/tasks/task-self-hosting.bb b/packages/tasks/task-self-hosting.bb
new file mode 100644
index 0000000000..a82d6a6bc3
--- /dev/null
+++ b/packages/tasks/task-self-hosting.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "All tools needed for OpenEmbedded build"
+SECTION = "devel"
+LICENSE = "MIT"
+RDEPENDS = "cpp gcc-symlinks binutils-symlinks \
+ perl perl-modules bitbake bash \
+ task-proper-tools glibc-utils \
+ libc-linux-headers-dev glibc-dev \
+ texinfo make cvs subversion monotone-6"
+
+#
+# quilt-native REQ bash and perl/perl-modules
+# binutils REQ texinfo
+#
+# bitbake will fetch all needed python modules
+#
+# toolchain:
+# - gcc-symlinks will fetch gcc
+# - binutils-symlinks will fetch binutils
+# - glibc-utils REQ cpp
+#
+# problems:
+# - binutils-synlinks conflict with busybox
+# - glibc-dev conflict with libc-linux-headers-dev
+# - perl is so granulated that it is probably impossible
+# to find out which packages are needed
+#
+
+ALLOW_EMPTY = "1"
+
+PACKAGE_ARCH = "all"