summaryrefslogtreecommitdiff
path: root/packages/tasks/task-openmoko-ui.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-12-19 10:02:27 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-12-19 10:02:27 +0000
commitc7e33ecf737e93f9ecec2cc609064bfd593f2b61 (patch)
treea657ac69b5e38e1887286933e9ae748e2267b27b /packages/tasks/task-openmoko-ui.bb
parentef93660d2fbd162ca59457c96d7e1cea9cd8b907 (diff)
parentf871fead79da276cf252c7a9ab1b33e33119b009 (diff)
merge of '074f227db84b62ec3c531c61efcd62fc6b429dc3'
and '5af64e0f29377b9ebbc655af469dd70d6a2f6dfb'
Diffstat (limited to 'packages/tasks/task-openmoko-ui.bb')
-rw-r--r--packages/tasks/task-openmoko-ui.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/packages/tasks/task-openmoko-ui.bb b/packages/tasks/task-openmoko-ui.bb
new file mode 100644
index 0000000000..e34bb42b2f
--- /dev/null
+++ b/packages/tasks/task-openmoko-ui.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "OpenMoko: GUI for the OpenMoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r71"
+
+inherit task
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+#
+# task-openmoko-ui
+#
+DESCRIPTION_task-openmoko-ui = "OpenMoko: The X11/Gtk+2 based native User Interface"
+PACKAGE_ARCH_task-openmoko-ui = "${MACHINE_ARCH}"
+RDEPENDS_task-openmoko-ui = "\
+ gdk-pixbuf-loader-png \
+ gdk-pixbuf-loader-gif \
+ gdk-pixbuf-loader-xpm \
+ gdk-pixbuf-loader-jpeg \
+ pango-module-basic-x \
+ pango-module-basic-fc \
+ gtk+ \
+ matchbox-wm \
+ ${XSERVER} \
+ xserver-kdrive-common \
+ xserver-nodm-init \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+ \
+ settings-daemon \
+ notification-daemon \
+ neod \
+ libnotify \
+ \
+ openmoko-session2 \
+ openmoko-sound-system2 \
+ openmoko-sound-theme-standard2 \
+ \
+ gpe-scap \
+"
+
+# Handle theming. FIXME: properly use machine database in a smart way,
+# taking into account not only size but also PPI! Ultimately this might
+# need recomputing some theme files and images on-the-fly :/ SVG and logical
+# theme description anyone? Or simply Edje to the rescue! :D
+THEMES = "openmoko-icon-theme-standard2 openmoko-theme-standard2"
+THEMES_a780 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_e680 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_a1200 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_rokre2 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_rokre6 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_magician = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+
+RDEPENDS_task-openmoko-ui += "${THEMES}"