summaryrefslogtreecommitdiff
path: root/packages/syslinux/syslinux-native_3.63.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-01-15 16:31:18 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-22 18:50:55 -0200
commitf01e6cb9955e8a7304abf8b391ed97385eacdb3b (patch)
tree6a98c83578442699f89dce2a4cf12a526dbb3231 /packages/syslinux/syslinux-native_3.63.bb
parentf487f048698f634f321acc80fce2e648b35a328e (diff)
syslinux-native: leave only 3.63 version
The only user (or a possible one) of it was OpenMoko but they were preferring the version 3.36 that is not available; so looks safe to bump it to 3.63 since it was't notice by them. The versions that has been droped are 2.11, 3.11 and 3.31.
Diffstat (limited to 'packages/syslinux/syslinux-native_3.63.bb')
-rw-r--r--packages/syslinux/syslinux-native_3.63.bb37
1 files changed, 36 insertions, 1 deletions
diff --git a/packages/syslinux/syslinux-native_3.63.bb b/packages/syslinux/syslinux-native_3.63.bb
index d9019a4ab4..471ef1bc8f 100644
--- a/packages/syslinux/syslinux-native_3.63.bb
+++ b/packages/syslinux/syslinux-native_3.63.bb
@@ -1,3 +1,38 @@
+# syslinux-native OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A multi-purpose linux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+LICENSE="GPL"
+PR="r1"
+
+# If you really want to run syslinux, you need mtools. We just want the
+# ldlinux.* stuff for now, so skip mtools-native
+DEPENDS="nasm-native"
+
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
-require syslinux3.inc
+S="${WORKDIR}/syslinux-${PV}"
+
+inherit native
+
+STAGE_TEMP="${WORKDIR}/stage_temp"
+
+do_stage() {
+ install -d ${STAGE_TEMP}
+ oe_runmake install INSTALLROOT="${STAGE_TEMP}"
+
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR}
+ install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR}
+
+ # When building media, the syslinux binary isn't nearly as useful
+ # as the DOS data files, so we copy those into a special location
+ # for usage during a image build stage
+
+ install -d ${STAGING_DATADIR}/syslinux
+ install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
+ install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
+ install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
+}