summaryrefslogtreecommitdiff
path: root/packages/sylpheed/sylpheed_2.0.0beta6.bb
diff options
context:
space:
mode:
authorPatrick Steiner <law@a1.net>2005-07-19 11:27:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-19 11:27:55 +0000
commitf1d95e32a275db0688d04f2d6ac255b2fb1771ba (patch)
tree9467df7ad79ff1c4c81cdcee5c535dff01518c5b /packages/sylpheed/sylpheed_2.0.0beta6.bb
parent09fb08598b5a2f396ff71ed1352ba9c0b82abb7f (diff)
added sylpheed 2.0.0beta6
Diffstat (limited to 'packages/sylpheed/sylpheed_2.0.0beta6.bb')
-rw-r--r--packages/sylpheed/sylpheed_2.0.0beta6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_2.0.0beta6.bb b/packages/sylpheed/sylpheed_2.0.0beta6.bb
new file mode 100644
index 0000000000..4fab8e8bb8
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.0.0beta6.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.0beta/sylpheed-2.0.0beta6.tar.bz2 \
+ file://sylpheed-gnutls_2.0.0beta6.patch;patch=1"
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+