summaryrefslogtreecommitdiff
path: root/packages/sword
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-11-14 19:53:02 +0000
committerMatt Reimer <mattjreimer@gmail.com>2006-11-14 19:53:02 +0000
commit188283505fbdd128396b366912974fc79d407d83 (patch)
tree07fce3c2e32f95c160e31661154bbede8b651f65 /packages/sword
parent1084c37f9a8fd913ffdee54fba4d5bbd31bef68a (diff)
parentfe6bc5b4cabb5fcf87b8944b4cfbe73bb48ceecf (diff)
merge of '0522ce6e18539b2787b0461c02f133fb7067acc9'
and 'ed6e67aa7fd65b6d6d815724100fcd050742b0f6'
Diffstat (limited to 'packages/sword')
-rw-r--r--packages/sword/sword_1.5.9.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/sword/sword_1.5.9.bb b/packages/sword/sword_1.5.9.bb
new file mode 100644
index 0000000000..362b75e57c
--- /dev/null
+++ b/packages/sword/sword_1.5.9.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+ oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sword/
+ for f in include/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sword/
+ done
+
+}
+
+FILES_${PN} = "${libdir}/libsword*so ${sysconfdir} ${bindir} ${datadir}"