summaryrefslogtreecommitdiff
path: root/packages/subversion/subversion_1.4.0.bb
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-08 19:22:08 +0000
committerMichael Krelin <hacker@klever.net>2007-05-08 19:22:08 +0000
commit02fb4610922c0944aa90b668b1238949a6bb3535 (patch)
treeffebabb22d1608d75d9b9d10afb202b5dc6df363 /packages/subversion/subversion_1.4.0.bb
parent2f1e00624712c31cfc2bd55a8d46ae5dab187de9 (diff)
subversion: added a patch to detect neon and enable dav protocol handler
Diffstat (limited to 'packages/subversion/subversion_1.4.0.bb')
-rw-r--r--packages/subversion/subversion_1.4.0.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/packages/subversion/subversion_1.4.0.bb b/packages/subversion/subversion_1.4.0.bb
index 3c65d1d0a8..a608aac063 100644
--- a/packages/subversion/subversion_1.4.0.bb
+++ b/packages/subversion/subversion_1.4.0.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "The Subversion (svn) client"
SECTION = "console/network"
DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
LICENSE = "Apache/BSD"
HOMEPAGE = "http://subversion.tigris.org"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
- file://disable-revision-install.patch;patch=1"
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
-EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${BUILD_SYS} \
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
--without-berkeley-db --without-apxs --without-apache \
--without-swig --with-apr=${STAGING_BINDIR_CROSS} \
--with-apr-util=${STAGING_BINDIR_CROSS}"
@@ -21,5 +23,6 @@ export LDFLAGS += " -L${STAGING_LIBDIR} "
do_configure() {
gnu-configize
libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
oe_runconf
}