summaryrefslogtreecommitdiff
path: root/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-01-05 19:25:48 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-01-05 19:25:48 +0000
commit2c88ed78a67665a962a5b9a5e977cbed8b333c22 (patch)
treefc2e664e4ed435ce6ebe42218f92e89c6ab0d4b7 /packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
parent5cc0bc5c6f897d58724a11978979575c9b588985 (diff)
parent742fb4ae71e6a7e655385086ba9edebbf00b6ebd (diff)
merge of '5e5ed72728986531bc9fcd00f87f56051f1fbff5'
and '897413a90458757cb227c0afbc74963d175a60a7'
Diffstat (limited to 'packages/speech-dispatcher/speech-dispatcher_0.6.5.bb')
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.5.bb26
1 files changed, 17 insertions, 9 deletions
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
index 68bfd8a347..d8e2b8ed3a 100644
--- a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
@@ -1,26 +1,33 @@
-DESCRIPTION = " Speech Dispatcher is a high-level device independent layer \
+DESCRIPTION = "Speech Dispatcher is a high-level device independent layer \
for speech synthesis through a simple, stable and well documented interface."
HOMEPAGE = "http://www.freebsoft.org/speechd/"
LICENSE = "GPLv2"
DEPENDS = "flite libdotconf glib-2.0"
-RPROVIDES += "speechd"
+RPROVIDES_${PN} += "speechd"
-PR = "r1"
+PR = "r5"
-inherit autotools
+inherit autotools update-rc.d
SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
+ file://speech-dispatcher.init \
file://srcMakefile.am.patch;patch=1 \
- file://confSpeechd.conf_00.patch;patch=1"
+ file://configSpeechd.conf.in_00.patch;patch=1"
LEAD_SONAME = "libspeechd.so"
+EXTRA_OECONF = " --with-espeak=yes --with-flite=no --with-ibmtts=no --with-nas=no --with-alsa=yes --with-pulse=yes "
+
+INITSCRIPT_NAME = "speech-dispatcher"
+INITSCRIPT_PARAMS = "defaults 45"
do_install() {
install -d ${D}${bindir}
install -d ${D}${includedir}
install -d ${D}${libdir}/${PN}-modules
- install -d ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/modules
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/speech-dispatcher
+ install -d ${D}${sysconfdir}/speech-dispatcher/modules
oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
@@ -31,8 +38,9 @@ do_install() {
install -m 0755 ${S}/src/server/.libs/speech-dispatcher ${D}${bindir}
install -m 0755 ${S}/src/modules/.libs/sd_* ${D}${libdir}/${PN}-modules/
- install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}
- install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/modules
+ install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}/speech-dispatcher
+ install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/speech-dispatcher/modules
+ install -m 0755 ${WORKDIR}/speech-dispatcher.init ${D}${sysconfdir}/init.d/speech-dispatcher
}
do_stage() {