summaryrefslogtreecommitdiff
path: root/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-01-03 02:01:39 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-01-03 02:01:39 +0000
commit055260657195d3b59e4d5761f889b07afcef690f (patch)
tree53a9ff34edbf1f97c2c15cc56da03f2ad1378b9f /packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
parent6cc8d18c134d775a13a36b4af7f58ee5ac01b602 (diff)
add speech-dispatcher (RPROVIDES speechd). needed by navit.
Diffstat (limited to 'packages/speech-dispatcher/speech-dispatcher_0.6.5.bb')
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
new file mode 100644
index 0000000000..23914ab00e
--- /dev/null
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = " Speech Dispatcher is a high-level device independent layer \
+for speech synthesis through a simple, stable and well documented interface."
+HOMEPAGE = "http://www.freebsoft.org/speechd/"
+LICENSE = "GPLv2"
+DEPENDS = "flite dotconf glib-2.0"
+RPROVIDES += "speechd"
+
+inherit autotools
+
+SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
+ file://srcMakefile.am.patch;patch=1 "
+
+LEAD_SONAME = "libspeechd.so"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${includedir}
+ install -d ${D}${libdir}/${PN}-modules
+
+ oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
+ oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
+
+ install -m 0644 ${S}/src/c/api/libspeechd.h ${D}${includedir}
+ install -m 0755 ${S}/src/c/clients/say/spd-say ${D}${bindir}
+ install -m 0755 ${S}/src/c/clients/spdsend/spdsend ${D}${bindir}
+ install -m 0755 ${S}/src/server/speech-dispatcher ${D}${bindir}
+ install -m 0755 ${S}/src/modules/sd_* ${D}${libdir}/${PN}-modules/
+}
+
+do_stage() {
+ install -m 0644 ${S}/src/c/api/libspeechd.h ${STAGING_INCDIR}
+ oe_libinstall -so -C src/c/api libspeechd ${STAGING_LIBDIR}
+}
+
+FILES_${PN} += "${libdir}/${PN}-modules/*"