summaryrefslogtreecommitdiff
path: root/packages/slugos-init
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-02-06 01:22:22 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 01:22:22 +0000
commit983378a2d3f3042997cbfb85683b238760bd9896 (patch)
tree02f82190d0ea646e61117eb690d0d7b47d4b7a66 /packages/slugos-init
parent76107d774ec7a96b7788d2f2b98b5621a04cfe71 (diff)
initscripts-slugos: modify the slugos checkroot.sh not to hang on fsck failure in 1.0
slugos-init: add a single_user_ok function in /etc/default/functions in 0.10 sysvinit: update slugos rcS with new options in 2.86 - this is to fix the fsck of the rootfs so that it will actually work safely on machines with no console.
Diffstat (limited to 'packages/slugos-init')
-rw-r--r--packages/slugos-init/files/functions14
-rw-r--r--packages/slugos-init/slugos-init_0.10.bb2
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/slugos-init/files/functions b/packages/slugos-init/files/functions
index ef10d65fb2..df74aea717 100644
--- a/packages/slugos-init/files/functions
+++ b/packages/slugos-init/files/functions
@@ -26,6 +26,20 @@ machine(){
esac
}
#
+# single_user_ok
+# if the machine is capable of single user interaction return
+# true, else return false. The result of this function is
+# preempted by setting SULOGIN to 'yes' or 'ok' in /etc/default/rcS
+single_user_ok() {
+ # list known good machines in the 'case'
+ test "$SULOGIN" = yes -o "$SULOGIN" = ok ||
+ case "$(machine)" in
+ ixdp*|avila|loft)
+ return 0;;
+ *) return 1;;
+ esac
+}
+#
# load_functions "source"
# load the functions in '/sbin/source' - relies on /sbin/source being
# a shell script and having support for this function.
diff --git a/packages/slugos-init/slugos-init_0.10.bb b/packages/slugos-init/slugos-init_0.10.bb
index 7c4c21f521..d8376ef2da 100644
--- a/packages/slugos-init/slugos-init_0.10.bb
+++ b/packages/slugos-init/slugos-init_0.10.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r54"
+PR = "r55"
SRC_URI = "file://boot/flash \
file://boot/disk \