summaryrefslogtreecommitdiff
path: root/packages/s3c24xx-utils
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-26 12:52:34 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-26 12:52:34 +0000
commitcf20be0e809f4452b6098ad028635c4b3c70a089 (patch)
treeac04b5b1144a6a47f7b6f13f50cf792c932b082b /packages/s3c24xx-utils
parent602390def86f581928680f00814cb8f2bd7ac5b9 (diff)
add gpio, a userspace utility to tweak the GPIOs on the s3c24xx platform
Diffstat (limited to 'packages/s3c24xx-utils')
-rw-r--r--packages/s3c24xx-utils/gpio_svn.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/s3c24xx-utils/gpio_svn.bb b/packages/s3c24xx-utils/gpio_svn.bb
new file mode 100644
index 0000000000..263161aa5d
--- /dev/null
+++ b/packages/s3c24xx-utils/gpio_svn.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A user-space tool to show and modify the state of GPIOs on the S3c24xx platform"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PV = "1.0+svn${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;proto=http"
+S = "${WORKDIR}/gpio"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -static -o gpio gpio.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 gpio ${D}${sbindir}
+}