summaryrefslogtreecommitdiff
path: root/packages/rp-pppoe/rp-pppoe_3.8.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-30 07:44:24 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-30 07:44:24 +0000
commit4e41c15ae2e5b1a6faae3806faf7f75cade38238 (patch)
tree29f948c682882f17d3892b6df4868b87d4960a93 /packages/rp-pppoe/rp-pppoe_3.8.bb
parentc0c50a38efb9a9f0161ad078dc778285716acfdd (diff)
rp-pppoe: Add version 3.8.
* The source for version 3.5 hasn't been available for a long time. * Make sure pppoe is installed suid root. * Always try to reconnect, pppd handles stop/starting pppoe. This prevents lots of annoying problems with pppoe totally giving up (debian patch) * Accept PPPoE packets from multicast addresses (debian patch) * Don't check the version of the hosts ppp, we don't support the older versions of ppp anyway so just remove those checks. * RDEPEND on ppp, which is needed to use pppoe * Hard code pppd and id paths, don't search for them on the host system.
Diffstat (limited to 'packages/rp-pppoe/rp-pppoe_3.8.bb')
-rw-r--r--packages/rp-pppoe/rp-pppoe_3.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/rp-pppoe/rp-pppoe_3.8.bb b/packages/rp-pppoe/rp-pppoe_3.8.bb
new file mode 100644
index 0000000000..c4d5ff88d2
--- /dev/null
+++ b/packages/rp-pppoe/rp-pppoe_3.8.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A user-mode PPPoE client and server suite for Linux"
+HOMEPAGE = "http://www.roaringpenguin.com/en/penguin/openSourceProducts/rpPppoe"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+RDEPENDS = "ppp"
+PR = "r0"
+
+SRC_URI = "http://www.roaringpenguin.com/files/download/${P}.tar.gz \
+ file://configure_in_cross.patch;patch=1;pnum=2 \
+ file://pppoe-src-restrictions.patch;patch=1;pnum=2"
+
+S = "${WORKDIR}/${P}/src"
+
+inherit autotools
+
+do_install() {
+ # Set timeout to 0. Fixes lots of reconnect issues
+ # Can't patch this in because it's outside of what we have {S} set to.
+ sed -i -e 's,\(CONNECT_TIMEOUT=\)30,\10,g' ${S}/../configs/pppoe.conf
+ # Install
+ oe_runmake -C ${S} RPM_INSTALL_ROOT=${D} docdir=${docdir} install
+}
+
+pkg_postinst() {
+ if [ x"$D" != "x" ]; then
+ exit 1
+ fi
+ chmod 4755 ${sbindir}/pppoe
+}