summaryrefslogtreecommitdiff
path: root/packages/rott
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/rott
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/rott')
-rw-r--r--packages/rott/files/gcc4.patch39
-rw-r--r--packages/rott/files/rott.jpgbin15509 -> 0 bytes
-rw-r--r--packages/rott/rott_1.0.bb21
3 files changed, 0 insertions, 60 deletions
diff --git a/packages/rott/files/gcc4.patch b/packages/rott/files/gcc4.patch
deleted file mode 100644
index 6a850533c7..0000000000
--- a/packages/rott/files/gcc4.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- rott-1.0/rott/rt_actor.c~gcc4
-+++ rott-1.0/rott/rt_actor.c
-@@ -430,11 +430,11 @@
- void AvoidPlayerMissile(objtype*ob);
- int EnvironmentDamage(objtype *ob);
-
--static int STOPSPEED = 0x200;
--static int PLAYERFRICTION = 0xe000;
--static int ACTORFRICTION = 0xf000;
--static int DIAGADJUST = 0xb504;
--static boolean MissileSound = true;
-+int STOPSPEED = 0x200;
-+int PLAYERFRICTION = 0xe000;
-+int ACTORFRICTION = 0xf000;
-+int DIAGADJUST = 0xb504;
-+boolean MissileSound = true;
-
-
-
---- rott-1.0/rott/rt_in.c~gcc4
-+++ rott-1.0/rott/rt_in.c
-@@ -155,9 +155,9 @@
- //
- //****************************************************************************]
-
--static KeyboardDef KbdDefs = {0x1d,0x38,0x47,0x48,0x49,0x4b,0x4d,0x4f,0x50,0x51};
--static JoystickDef JoyDefs[MaxJoys];
--static ControlType Controls[MAXPLAYERS];
-+KeyboardDef KbdDefs = {0x1d,0x38,0x47,0x48,0x49,0x4b,0x4d,0x4f,0x50,0x51};
-+JoystickDef JoyDefs[MaxJoys];
-+ControlType Controls[MAXPLAYERS];
-
-
- static boolean IN_Started;
diff --git a/packages/rott/files/rott.jpg b/packages/rott/files/rott.jpg
deleted file mode 100644
index e0d2807c39..0000000000
--- a/packages/rott/files/rott.jpg
+++ /dev/null
Binary files differ
diff --git a/packages/rott/rott_1.0.bb b/packages/rott/rott_1.0.bb
deleted file mode 100644
index e1fc4e6a74..0000000000
--- a/packages/rott/rott_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "Rise of the Triad - an SDL based Doom clone - QtE based Palmtop Environments Edition"
-HOMEPAGE = "http://www.icculus.org/root"
-LICENSE = "GPL"
-PR = "r2"
-
-APPIMAGE = "${WORKDIR}/rott.jpg"
-
-SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz \
- file://gcc4.patch;patch=1;pnum=2 \
- file://rott.jpg"
-S = "${WORKDIR}/rott-${PV}/rott"
-
-CFLAGS += "-DPLATFORM_UNIX"
-EXTRA_OEMAKE = 'SDL_INC_DIR=${STAGING_INCDIR}/SDL CC="${CC}" EXTRALDFLAGS="${LDFLAGS}"'
-
-inherit sdl
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 rott ${D}${bindir}
-}