summaryrefslogtreecommitdiff
path: root/packages/qpe-gaim/qpe-libgaim_1.4.0.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-07-08 18:00:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-08 18:00:46 +0000
commit0fd2c307d607b81b5e08ae3468e95ad662148df9 (patch)
tree2bb542e1c62e2028983c85aa146f38d419cdec15 /packages/qpe-gaim/qpe-libgaim_1.4.0.bb
parent7d816d1cf57d263d52bb1990de7338165b65fd37 (diff)
qpe-libgaim_1.3.1.bb
-Rename to qpe-libgaim_1.4.0.bb as it was released
Diffstat (limited to 'packages/qpe-gaim/qpe-libgaim_1.4.0.bb')
-rw-r--r--packages/qpe-gaim/qpe-libgaim_1.4.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/packages/qpe-gaim/qpe-libgaim_1.4.0.bb b/packages/qpe-gaim/qpe-libgaim_1.4.0.bb
new file mode 100644
index 0000000000..824dee5c39
--- /dev/null
+++ b/packages/qpe-gaim/qpe-libgaim_1.4.0.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "glib-2.0 gnutls"
+RDEPENDS = "libgaim-plugins"
+LICENSE = "GPL"
+HOMEPAGE = "http://gaim.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gaim/gaim-${PV}.tar.bz2 \
+ file://dont-look-for-gtk.patch;patch=1 \
+ file://libgaim.patch;patch=1 "
+
+S = "${WORKDIR}/gaim-${PV}"
+
+inherit autotools
+
+EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
+ --disable-screensaver --disable-sm --disable-glibtest \
+ --disable-gtktest --disable-startup-notification \
+ --disable-gevolution --disable-aotest --disable-audiofiletest \
+ --disable-x --without-x --without-gtk --disable-gtk \
+ --enable-gnutls=y"
+
+CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
+
+do_stage() {
+ oe_libinstall -so -C src libgaim ${QTDIR}/lib
+
+ # install headers
+ GAIM_DIR=${STAGING_INCDIR}/gaim
+ install -d $GAIM_DIR
+
+ for header in account.h accountopt.h away.h blist.h buddyicon.h cmds.h config.h connection.h conversation.h core.h debug.h eventloop.h ft.h gaim.h imgstore.h log.h md5.h network.h notify.h plugin.h pluginpref.h pounce.h prefix.h prefs.h privacy.h proxy.h prpl.h request.h roomlist.h server.h sha.h signals.h sound.h sslconn.h status.h stringref.h util.h value.h version.h xmlnode.h
+ do
+ if [ -e ${S}/src/$header ]; then
+ install -m 0644 ${S}/src/$header $GAIM_DIR
+ fi
+ if [ -e ${S}/$header ]; then
+ install -m 0644 ${S}/$header $GAIM_DIR
+ fi
+ done
+}
+
+#FIXME: use do_packages to create individual packages for each of the plugins
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${libdir}/gaim', d)
+ do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
+}
+
+PACKAGES += "libgaim-plugins"
+FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
+