summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-24 08:51:40 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-24 08:51:40 +0000
commitd948d16754b7cda41bf4ab402d410dee306bd599 (patch)
tree2fab21398b661eb4d9a9fc7b3f90aeda4d668088 /packages/python
parent50373753d65cab18022e734ef3feb117295c5909 (diff)
python-setuptools[-native] 0.6c8 fix log usage bug
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-setuptools-native_0.6c8.bb4
-rw-r--r--packages/python/python-setuptools/.mtn2git_empty0
-rw-r--r--packages/python/python-setuptools/fix-log-usage.patch13
-rw-r--r--packages/python/python-setuptools_0.6c8.bb7
4 files changed, 20 insertions, 4 deletions
diff --git a/packages/python/python-setuptools-native_0.6c8.bb b/packages/python/python-setuptools-native_0.6c8.bb
index b7716d8cac..0bbf9c32fc 100644
--- a/packages/python/python-setuptools-native_0.6c8.bb
+++ b/packages/python/python-setuptools-native_0.6c8.bb
@@ -1,9 +1,9 @@
require python-setuptools_${PV}.bb
inherit native
+FILESPATH = "${FILE_DIRNAME}/python-setuptools"
DEPENDS = "python-native"
do_stage() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- ${STAGING_BINDIR_NATIVE}/python setup.py install
+ distutils_stage_all
}
diff --git a/packages/python/python-setuptools/.mtn2git_empty b/packages/python/python-setuptools/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-setuptools/.mtn2git_empty
diff --git a/packages/python/python-setuptools/fix-log-usage.patch b/packages/python/python-setuptools/fix-log-usage.patch
new file mode 100644
index 0000000000..6363c850c2
--- /dev/null
+++ b/packages/python/python-setuptools/fix-log-usage.patch
@@ -0,0 +1,13 @@
+Index: setuptools-0.6c8/setuptools/command/sdist.py
+===================================================================
+--- setuptools-0.6c8.orig/setuptools/command/sdist.py
++++ setuptools-0.6c8/setuptools/command/sdist.py
+@@ -95,7 +95,7 @@ def entries_finder(dirname, filename):
+ for match in entries_pattern.finditer(data):
+ yield joinpath(dirname,unescape(match.group(1)))
+ else:
+- log.warn("unrecognized .svn/entries format in %s", dirname)
++ print ("unrecognized .svn/entries format in %s", dirname)
+
+
+ finders = [
diff --git a/packages/python/python-setuptools_0.6c8.bb b/packages/python/python-setuptools_0.6c8.bb
index 19f73d3f67..5b82ecea69 100644
--- a/packages/python/python-setuptools_0.6c8.bb
+++ b/packages/python/python-setuptools_0.6c8.bb
@@ -5,9 +5,12 @@ PRIORITY = "optional"
LICENSE = "MIT-like"
RDEPENDS = "python-distutils python-compression"
SRCNAME = "setuptools"
-PR = "ml0"
+PR = "ml1"
-SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+ file://fix-log-usage.patch;patch=1 \
+"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils