summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-12 14:07:07 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-12 14:07:07 +0000
commita596e3e23fd60995a89318bd3518797a94bfa1d8 (patch)
tree5e5c722ff36140e861af5b2a0c4ec85fa4c9c631 /packages/python
parentc402c5af43c5881feba53c224b27cb2f0c58bec0 (diff)
python-native 2.5.1 add distutils patch to catch up with newer SWIG versions
This fixes the infamous: TypeError: swig_sources() takes exactly 2 arguments (3 given)
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-native-2.5.1/catchup-with-swig.patch13
-rw-r--r--packages/python/python-native_2.5.1.bb20
2 files changed, 22 insertions, 11 deletions
diff --git a/packages/python/python-native-2.5.1/catchup-with-swig.patch b/packages/python/python-native-2.5.1/catchup-with-swig.patch
new file mode 100644
index 0000000000..f049b759f4
--- /dev/null
+++ b/packages/python/python-native-2.5.1/catchup-with-swig.patch
@@ -0,0 +1,13 @@
+Index: Python-2.5.1/Lib/distutils/command/build_ext.py
+===================================================================
+--- Python-2.5.1.orig/Lib/distutils/command/build_ext.py
++++ Python-2.5.1/Lib/distutils/command/build_ext.py
+@@ -513,7 +513,7 @@ class build_ext (Command):
+ target_lang=language)
+
+
+- def swig_sources (self, sources, extension):
++ def swig_sources (self, sources, extension=None):
+
+ """Walk the list of source files in 'sources', looking for SWIG
+ interface (.i) files. Run SWIG on all that are found, and
diff --git a/packages/python/python-native_2.5.1.bb b/packages/python/python-native_2.5.1.bb
index ea6e257043..3f58d36a2e 100644
--- a/packages/python/python-native_2.5.1.bb
+++ b/packages/python/python-native_2.5.1.bb
@@ -4,15 +4,18 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
DEPENDS = ""
-PR = "ml1"
+PR = "ml2"
EXCLUDE_FROM_WORLD = "1"
-SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://cross-distutils.patch;patch=1 \
- file://dont-modify-shebang-line.patch;patch=1 \
- file://default-is-optimized.patch;patch=1"
+SRC_URI = "\
+ http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://bindir-libdir.patch;patch=1 \
+ file://cross-distutils.patch;patch=1 \
+ file://dont-modify-shebang-line.patch;patch=1 \
+ file://default-is-optimized.patch;patch=1 \
+ file://catchup-with-swig.patch;patch=1 \
+"
S = "${WORKDIR}/Python-${PV}"
inherit autotools native
@@ -24,11 +27,6 @@ EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \
--without-cxx --with-signal-module --with-wctype-functions"
EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
-#do_configure() {
-# # the autofoo stuff is too old to allow regenerating
-# oe_runconf
-#}
-
do_stage_append() {
install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/
}