summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2008-05-01 13:43:48 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2008-05-01 13:43:48 +0000
commit6827eda9aeb9ea33d9ca56bf864b7b0605e0447d (patch)
tree6025d86bc0cec366692fdb6864da7b25cef2cd36 /packages/python
parent93c598646b4a192331b77816048fbde223f57924 (diff)
parent4677e9577829e07467b025e476c9ec96d00fb21f (diff)
merge of '9bb9579fd7698d62103b3f88f6d0910f8ba1e53d'
and 'd8f83de5204562e9c23bd329d59d35006de0f0f8'
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5-manifest.inc6
-rw-r--r--packages/python/python-setuptools-native_0.6c6.bb8
-rw-r--r--packages/python/python-setuptools_0.6c6.bb7
-rw-r--r--packages/python/python-simplejson_1.7.1.bb5
-rw-r--r--packages/python/python_2.5.2.bb2
5 files changed, 15 insertions, 13 deletions
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index fda9f4143a..06c187fe91 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,5 +1,5 @@
########################################################################################################################
-### AUTO-GENERATED by '../../contrib/python/generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Thu Apr 10 16:47:00 2008
+### AUTO-GENERATED by '../../contrib/python/generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Thu May 1 12:24:55 2008
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -68,9 +68,9 @@ RDEPENDS_python-compiler="python-core"
FILES_python-compiler="${libdir}/python2.5/compiler "
DESCRIPTION_python-compression="Python High Level Compression Support"
-PR_python-compression="ml0"
+PR_python-compression="ml1"
RDEPENDS_python-compression="python-core python-zlib"
-FILES_python-compression="${libdir}/python2.5/gzip.* ${libdir}/python2.5/zipfile.* "
+FILES_python-compression="${libdir}/python2.5/gzip.* ${libdir}/python2.5/zipfile.* ${libdir}/python2.5/tarfile.* "
DESCRIPTION_python-re="Python Regular Expression APIs"
PR_python-re="ml0"
diff --git a/packages/python/python-setuptools-native_0.6c6.bb b/packages/python/python-setuptools-native_0.6c6.bb
new file mode 100644
index 0000000000..1b9f90911d
--- /dev/null
+++ b/packages/python/python-setuptools-native_0.6c6.bb
@@ -0,0 +1,8 @@
+require python-setuptools_${PV}.bb
+
+DEPENDS = "python-native"
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install
+}
diff --git a/packages/python/python-setuptools_0.6c6.bb b/packages/python/python-setuptools_0.6c6.bb
index ef56b9b652..721b29961e 100644
--- a/packages/python/python-setuptools_0.6c6.bb
+++ b/packages/python/python-setuptools_0.6c6.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "MIT-like"
-RDEPENDS = "python-core python-zlib"
+RDEPENDS = "python-distutils python-compression"
SRCNAME = "setuptools"
PR = "ml1"
@@ -15,8 +15,3 @@ inherit distutils
do_install_prepend() {
install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
}
-
-do_stage() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- ${STAGING_BINDIR_NATIVE}/python setup.py install
-}
diff --git a/packages/python/python-simplejson_1.7.1.bb b/packages/python/python-simplejson_1.7.1.bb
index 129f4fb9eb..67270f2df1 100644
--- a/packages/python/python-simplejson_1.7.1.bb
+++ b/packages/python/python-simplejson_1.7.1.bb
@@ -3,14 +3,13 @@ HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "MIT"
-DEPENDS = "python-setuptools"
# python-netserver is needed for cgi stuff
# python-zlib is needed to unpack egg created by setuptools
RDEPENDS = "python-core python-re python-io python-netserver python-zlib"
SRCNAME = "simplejson"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://cheeseshop.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit distutils
+inherit setuptools
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index 325e541b97..7f30badfad 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
# bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml2"
+PR = "ml3"
PYTHON_MAJMIN = "2.5"