summaryrefslogtreecommitdiff
path: root/packages/python/python-setuptools_0.6c9.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-14 00:38:40 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-14 00:38:40 +0000
commit6f25145ab702271fac182267ba3f604af00a6e27 (patch)
treec6e02ad2b6080efe1c41107e222e73c88008e73c /packages/python/python-setuptools_0.6c9.bb
parent1ddd7b0f49aa84d4a3d61b4b857d261acac3875d (diff)
python-setuptools[-native]: 0.6c8 -> 0.6c9
Diffstat (limited to 'packages/python/python-setuptools_0.6c9.bb')
-rw-r--r--packages/python/python-setuptools_0.6c9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/python/python-setuptools_0.6c9.bb b/packages/python/python-setuptools_0.6c9.bb
new file mode 100644
index 0000000000..179129eb60
--- /dev/null
+++ b/packages/python/python-setuptools_0.6c9.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+RDEPENDS = "python-distutils python-compression"
+SRCNAME = "setuptools"
+PR = "ml0"
+
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+ file://fix-log-usage.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS = "\
+ python-distutils \
+ python-compression \
+"