summaryrefslogtreecommitdiff
path: root/packages/python/python-pyiw_0.3.3.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-03-22 00:32:21 +0000
committerHolger Freyther <zecke@selfish.org>2008-03-22 00:32:21 +0000
commit0362af65b95845f571763fa56e6031a8089091fc (patch)
treebae11f352af2fc04b16ae6ddae46fc6cb51b36f5 /packages/python/python-pyiw_0.3.3.bb
parent2f8d9c7a57e00b9acd7f7ac445b3ee6cd4eba886 (diff)
parenta4535d80cb60e8eb76cdd2570e76b39eee2332d0 (diff)
merge of '4216327dbc55e359d557266da86971e66ff5f595'
and 'd72643015c099d3f2c3ec5c5bb1294365effbe54'
Diffstat (limited to 'packages/python/python-pyiw_0.3.3.bb')
-rw-r--r--packages/python/python-pyiw_0.3.3.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/packages/python/python-pyiw_0.3.3.bb b/packages/python/python-pyiw_0.3.3.bb
index aa86a07e8f..aaa18c7ee9 100644
--- a/packages/python/python-pyiw_0.3.3.bb
+++ b/packages/python/python-pyiw_0.3.3.bb
@@ -5,25 +5,24 @@ SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "wireless-tools"
-RDEPENDS = "python-core libiw"
+RDEPENDS = "python-core"
PR = "ml0"
+inherit autotools pkgconfig distutils-base
+
+CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR}"
+
SRC_URI = "http://downloads.emperorlinux.com/contrib/pyiw/pyiw-${PV}.tbz2 \
file://Makefile"
-
-S="${WORKDIR}/pyiw-${PV}"
+S = "${WORKDIR}/pyiw-${PV}"
do_unpack_real () {
- tar jxvf pyiw-${PV}.tbz2
+ tar jxvf ${DL_DIR}/pyiw-${PV}.tbz2
cp Makefile pyiw-${PV}/
}
do_unpack_real[dirs] = "${WORKDIR}"
addtask unpack_real before do_patch after do_unpack
-inherit autotools pkgconfig distutils-base
-
-CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR}"
-
do_install() {
install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
install -m 0755 pyiw.so ${D}${libdir}/${PYTHON_DIR}/site-packages/pyiw.so