summaryrefslogtreecommitdiff
path: root/packages/python/python-pygame_1.6.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-09 18:08:07 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-09 18:08:07 +0000
commit0afa6f0f95665dcd9e8532533117d97776ef207e (patch)
tree6f3aae5274330fe9ead8d4e7eff8a563c30580fa /packages/python/python-pygame_1.6.bb
parentd2066d7ac914c080d91716f2657a52d8bf2f4361 (diff)
add a couple of license statements and remove rdepends to python-core since this is being added through distutils.bbclass
BKrev: 41b89487qJM8uurTe2Ldlw89HbmdKQ
Diffstat (limited to 'packages/python/python-pygame_1.6.bb')
-rw-r--r--packages/python/python-pygame_1.6.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/python/python-pygame_1.6.bb b/packages/python/python-pygame_1.6.bb
index e69de29bb2..c07a07c75c 100644
--- a/packages/python/python-pygame_1.6.bb
+++ b/packages/python/python-pygame_1.6.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python libSDL Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "LGPL"
+RDEPENDS = "python-core python-numeric"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
+SRCNAME = "pygame"
+
+SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}.tar.gz \
+ file://qpe.patch;patch=1 \
+ file://Setup"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >Setup
+ cat ${WORKDIR}/Setup >>Setup
+}