summaryrefslogtreecommitdiff
path: root/packages/python/python-numpy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/python/python-numpy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/python/python-numpy')
-rw-r--r--packages/python/python-numpy/arm/config.h21
-rw-r--r--packages/python/python-numpy/arm/numpyconfig.h17
-rw-r--r--packages/python/python-numpy/trycompile.diff33
-rw-r--r--packages/python/python-numpy/unbreak-assumptions.diff16
4 files changed, 0 insertions, 87 deletions
diff --git a/packages/python/python-numpy/arm/config.h b/packages/python/python-numpy/arm/config.h
deleted file mode 100644
index 17ef186d56..0000000000
--- a/packages/python/python-numpy/arm/config.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
-/* #define SIZEOF_SHORT 2 */
-/* #define SIZEOF_INT 4 */
-/* #define SIZEOF_LONG 4 */
-/* #define SIZEOF_FLOAT 4 */
-/* #define SIZEOF_DOUBLE 8 */
-#define SIZEOF_LONG_DOUBLE 12
-#define SIZEOF_PY_INTPTR_T 4
-/* #define SIZEOF_LONG_LONG 8 */
-#define SIZEOF_PY_LONG_LONG 8
-/* #define CHAR_BIT 8 */
-#define MATHLIB m
-#define HAVE_FLOAT_FUNCS
-#define HAVE_LOG1P
-#define HAVE_EXPM1
-#define HAVE_INVERSE_HYPERBOLIC
-#define HAVE_INVERSE_HYPERBOLIC_FLOAT
-#define HAVE_ISNAN
-#define HAVE_ISINF
-#define HAVE_RINT
-
diff --git a/packages/python/python-numpy/arm/numpyconfig.h b/packages/python/python-numpy/arm/numpyconfig.h
deleted file mode 100644
index c4bf6547f0..0000000000
--- a/packages/python/python-numpy/arm/numpyconfig.h
+++ /dev/null
@@ -1,17 +0,0 @@
-/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
-/*
- * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
- * */
-#define NPY_SIZEOF_SHORT 2
-#define NPY_SIZEOF_INT 4
-#define NPY_SIZEOF_LONG 4
-#define NPY_SIZEOF_FLOAT 4
-#define NPY_SIZEOF_DOUBLE 8
-#define NPY_SIZEOF_LONGDOUBLE 12
-#define NPY_SIZEOF_PY_INTPTR_T 4
-#define NPY_NO_SMP 0
-
-#define NPY_SIZEOF_LONGLONG 8
-#define NPY_SIZEOF_PY_LONG_LONG 8
-/* #define CHAR_BIT 8 */
-
diff --git a/packages/python/python-numpy/trycompile.diff b/packages/python/python-numpy/trycompile.diff
deleted file mode 100644
index 3ab3d72f2c..0000000000
--- a/packages/python/python-numpy/trycompile.diff
+++ /dev/null
@@ -1,33 +0,0 @@
---- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
-+++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
-@@ -80,8 +80,7 @@
- raise SystemError,\
- "Non-existing %s. Perhaps you need to install"\
- " python-dev|python-devel." % (python_h)
-- result = config_cmd.try_run(tc,include_dirs=[python_include],
-- library_dirs = default_lib_dirs)
-+ result = config_cmd.try_compile(tc)
- if not result:
- raise SystemError,"Failed to test configuration. "\
- "See previous error messages for more information."
-@@ -95,7 +94,7 @@
- if mathlib:
- mathlibs_choices.insert(0,mathlib.split(','))
- for libs in mathlibs_choices:
-- if config_cmd.try_run(tc,libraries=libs):
-+ if config_cmd.try_compile(tc):
- mathlibs = libs
- break
- else:
-@@ -180,10 +179,7 @@
- " python-dev|python-devel." % (python_h)
-
- config.numpy_include_dirs
-- result = config_cmd.try_run(testcode,
-- include_dirs = [python_include] + \
-- config.numpy_include_dirs,
-- library_dirs = default_lib_dirs)
-+ result = config_cmd.try_compile(testcode)
-
- if not result:
- raise SystemError,"Failed to generate numpy configuration. "\
diff --git a/packages/python/python-numpy/unbreak-assumptions.diff b/packages/python/python-numpy/unbreak-assumptions.diff
deleted file mode 100644
index c5b448167f..0000000000
--- a/packages/python/python-numpy/unbreak-assumptions.diff
+++ /dev/null
@@ -1,16 +0,0 @@
---- /tmp/system_info.py 2008-08-22 00:38:16.000000000 +0200
-+++ numpy-1.1.1/numpy/distutils/system_info.py 2008-08-22 00:40:33.013198000 +0200
-@@ -137,11 +137,8 @@
- default_x11_lib_dirs = []
- default_x11_include_dirs = []
- else:
-- default_lib_dirs = ['/usr/local/lib', '/opt/lib', '/usr/lib',
-- '/opt/local/lib', '/sw/lib']
-- default_include_dirs = ['/usr/local/include',
-- '/opt/include', '/usr/include',
-- '/opt/local/include', '/sw/include']
-+ default_lib_dirs = ['/non-existant-dir']
-+ default_include_dirs = ['non-existant-dir']
- default_src_dirs = ['.','/usr/local/src', '/opt/src','/sw/src']
-
- try: