summaryrefslogtreecommitdiff
path: root/packages/python/python-numpy/trycompile.diff
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-09-04 10:17:18 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-09-04 10:17:18 +0000
commitae63a4dad7b06af132c6ba5bdb5fb98b2231525a (patch)
tree62d8fae898721cffb503baa6c43ba795427045b9 /packages/python/python-numpy/trycompile.diff
parent309c832c2c21ceb97fd589ebce8327d0d2bba731 (diff)
parent3c20604cd26ca8da11ac9afb669629c20355c4e4 (diff)
merge of '0d3b0d788fccfc1c07e0da07e8f8596c062e2ef2'
and '8a4df13bdb5d6b154edb85a4b71e38ac457670a0'
Diffstat (limited to 'packages/python/python-numpy/trycompile.diff')
-rw-r--r--packages/python/python-numpy/trycompile.diff33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/python/python-numpy/trycompile.diff b/packages/python/python-numpy/trycompile.diff
new file mode 100644
index 0000000000..3ab3d72f2c
--- /dev/null
+++ b/packages/python/python-numpy/trycompile.diff
@@ -0,0 +1,33 @@
+--- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
++++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
+@@ -80,8 +80,7 @@
+ raise SystemError,\
+ "Non-existing %s. Perhaps you need to install"\
+ " python-dev|python-devel." % (python_h)
+- result = config_cmd.try_run(tc,include_dirs=[python_include],
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(tc)
+ if not result:
+ raise SystemError,"Failed to test configuration. "\
+ "See previous error messages for more information."
+@@ -95,7 +94,7 @@
+ if mathlib:
+ mathlibs_choices.insert(0,mathlib.split(','))
+ for libs in mathlibs_choices:
+- if config_cmd.try_run(tc,libraries=libs):
++ if config_cmd.try_compile(tc):
+ mathlibs = libs
+ break
+ else:
+@@ -180,10 +179,7 @@
+ " python-dev|python-devel." % (python_h)
+
+ config.numpy_include_dirs
+- result = config_cmd.try_run(testcode,
+- include_dirs = [python_include] + \
+- config.numpy_include_dirs,
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(testcode)
+
+ if not result:
+ raise SystemError,"Failed to generate numpy configuration. "\