summaryrefslogtreecommitdiff
path: root/packages/python/python-numpy/trycompile.diff
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-01 18:06:23 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-01 18:06:23 +0000
commita2034d65b71cc8c6ff7b3fb15f3991b45c799ea3 (patch)
tree5ec74f206dd9e151453aa5bed4708eab2757c100 /packages/python/python-numpy/trycompile.diff
parent2bad67782e38ad0dc2f27a956dbb933ae4bbd32c (diff)
parent282080022fd318c6239f9723e789be33655fe056 (diff)
merge of '99187c0da3a302acfa7fa4f93194f5f358f40d92'
and 'bfe16c15aa0c506913d70d09dc1dc9fcd8fabf94'
Diffstat (limited to 'packages/python/python-numpy/trycompile.diff')
-rw-r--r--packages/python/python-numpy/trycompile.diff33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/python/python-numpy/trycompile.diff b/packages/python/python-numpy/trycompile.diff
new file mode 100644
index 0000000000..3ab3d72f2c
--- /dev/null
+++ b/packages/python/python-numpy/trycompile.diff
@@ -0,0 +1,33 @@
+--- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
++++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
+@@ -80,8 +80,7 @@
+ raise SystemError,\
+ "Non-existing %s. Perhaps you need to install"\
+ " python-dev|python-devel." % (python_h)
+- result = config_cmd.try_run(tc,include_dirs=[python_include],
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(tc)
+ if not result:
+ raise SystemError,"Failed to test configuration. "\
+ "See previous error messages for more information."
+@@ -95,7 +94,7 @@
+ if mathlib:
+ mathlibs_choices.insert(0,mathlib.split(','))
+ for libs in mathlibs_choices:
+- if config_cmd.try_run(tc,libraries=libs):
++ if config_cmd.try_compile(tc):
+ mathlibs = libs
+ break
+ else:
+@@ -180,10 +179,7 @@
+ " python-dev|python-devel." % (python_h)
+
+ config.numpy_include_dirs
+- result = config_cmd.try_run(testcode,
+- include_dirs = [python_include] + \
+- config.numpy_include_dirs,
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(testcode)
+
+ if not result:
+ raise SystemError,"Failed to generate numpy configuration. "\