summaryrefslogtreecommitdiff
path: root/packages/python/python-numpy/trycompile.diff
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-01 18:12:37 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-01 18:12:37 +0000
commit5e6a273f44ed3729a91e2e27d8fc5e6097012a5a (patch)
tree22d07e0bf70f0326911af65f14159d566d853cd6 /packages/python/python-numpy/trycompile.diff
parent754959a5d8683ad7bb10b87e8042d9edcc3a53fe (diff)
parenta637f0c537b380165e61755028a26894b58e4f14 (diff)
merge of '5031449809d92a9131e43cf42ee07eaecb4fbeff'
and '61389ef93b16ad371a1a7c82bc60a4f061055b35'
Diffstat (limited to 'packages/python/python-numpy/trycompile.diff')
-rw-r--r--packages/python/python-numpy/trycompile.diff33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/python/python-numpy/trycompile.diff b/packages/python/python-numpy/trycompile.diff
new file mode 100644
index 0000000000..3ab3d72f2c
--- /dev/null
+++ b/packages/python/python-numpy/trycompile.diff
@@ -0,0 +1,33 @@
+--- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
++++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
+@@ -80,8 +80,7 @@
+ raise SystemError,\
+ "Non-existing %s. Perhaps you need to install"\
+ " python-dev|python-devel." % (python_h)
+- result = config_cmd.try_run(tc,include_dirs=[python_include],
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(tc)
+ if not result:
+ raise SystemError,"Failed to test configuration. "\
+ "See previous error messages for more information."
+@@ -95,7 +94,7 @@
+ if mathlib:
+ mathlibs_choices.insert(0,mathlib.split(','))
+ for libs in mathlibs_choices:
+- if config_cmd.try_run(tc,libraries=libs):
++ if config_cmd.try_compile(tc):
+ mathlibs = libs
+ break
+ else:
+@@ -180,10 +179,7 @@
+ " python-dev|python-devel." % (python_h)
+
+ config.numpy_include_dirs
+- result = config_cmd.try_run(testcode,
+- include_dirs = [python_include] + \
+- config.numpy_include_dirs,
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(testcode)
+
+ if not result:
+ raise SystemError,"Failed to generate numpy configuration. "\