summaryrefslogtreecommitdiff
path: root/packages/python/python-numpy/arm/numpyconfig.h
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-01 10:16:05 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-01 10:16:05 +0000
commit19a4b765a694c070bc50477026cda03143af34df (patch)
tree34f947843d3f11ef366063017d876a76841bb258 /packages/python/python-numpy/arm/numpyconfig.h
parent9ede41ef1e0e03712e110052dc7ec6fa6d1b81f1 (diff)
python-numpy: add gross hack to make it build
Diffstat (limited to 'packages/python/python-numpy/arm/numpyconfig.h')
-rw-r--r--packages/python/python-numpy/arm/numpyconfig.h17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/python/python-numpy/arm/numpyconfig.h b/packages/python/python-numpy/arm/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/packages/python/python-numpy/arm/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+