summaryrefslogtreecommitdiff
path: root/packages/python/python-dbus_0.23.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/python/python-dbus_0.23.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/python/python-dbus_0.23.bb')
-rw-r--r--packages/python/python-dbus_0.23.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/python/python-dbus_0.23.bb b/packages/python/python-dbus_0.23.bb
index e69de29bb2..56bff28849 100644
--- a/packages/python/python-dbus_0.23.bb
+++ b/packages/python/python-dbus_0.23.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
+RDEPENDS = "dbus"
+PR = "ml1"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://tmpdir.patch;patch=1 \
+ file://gettext.patch;patch=1"
+S = "${WORKDIR}/dbus-${PV}"
+
+inherit autotools pkgconfig gettext
+
+EXTRA_OECONF = "--disable-qt --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x --enable-python"
+
+FILES_${PN} = "${libdir}/python2.4/site-packages/dbus.* ${libdir}/python2.4/site-packages/dbus_bindings.so"
+