summaryrefslogtreecommitdiff
path: root/packages/python/python-2.5.2/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2008-02-28 11:18:34 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2008-02-28 11:18:34 +0000
commitf5b0cc9973d24a6e6bb9981a5ba16cf57095d1d3 (patch)
tree76334941e8a143411bf13951187cf2c8c0688c7d /packages/python/python-2.5.2/fix-tkinter-detection.patch
parent0108e4109915cb8bb54212fc1a2985b81af4f7d5 (diff)
parenta6aca0c99ea61a1cee31657bef1017d824e24c82 (diff)
merge of '17c778274717898b377338f8552576cb4fd350eb'
and '662ae9dafb4c25857c0afa36b3303e10fdd8cea6'
Diffstat (limited to 'packages/python/python-2.5.2/fix-tkinter-detection.patch')
-rw-r--r--packages/python/python-2.5.2/fix-tkinter-detection.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/python/python-2.5.2/fix-tkinter-detection.patch b/packages/python/python-2.5.2/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..93bd343381
--- /dev/null
+++ b/packages/python/python-2.5.2/fix-tkinter-detection.patch
@@ -0,0 +1,41 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: Python-2.5.1/setup.py
+===================================================================
+--- Python-2.5.1.orig/setup.py
++++ Python-2.5.1/setup.py
+@@ -1227,7 +1227,7 @@ class PyBuildExt(build_ext):
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1246,22 +1246,6 @@ class PyBuildExt(build_ext):
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)