summaryrefslogtreecommitdiff
path: root/packages/python/python-2.4.3/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-03-30 16:48:13 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-30 16:48:13 +0000
commit3b7dddd7bc2d21c17b99a3fae6ae83a495a704f4 (patch)
tree6a97b0808ef34fc9d2b887e7a613da83f9e5b5de /packages/python/python-2.4.3/fix-tkinter-detection.patch
parent6da5f18190e4348f33125ba1546944e6613eb93b (diff)
parent3f4c13aa412fde10108c0484627aa69e6e3d577a (diff)
merge of 4089b02c1852c1619a06b04106854c9297b0bcbc
and 9f344d76f36ce0e29d4c8846cf1ec7be90ab5ff8
Diffstat (limited to 'packages/python/python-2.4.3/fix-tkinter-detection.patch')
-rw-r--r--packages/python/python-2.4.3/fix-tkinter-detection.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/python/python-2.4.3/fix-tkinter-detection.patch b/packages/python/python-2.4.3/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..602aa8e021
--- /dev/null
+++ b/packages/python/python-2.4.3/fix-tkinter-detection.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Python-2.4.1/setup.py~fix-tkinter-detection
++++ Python-2.4.1/setup.py
+@@ -999,7 +999,7 @@
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1018,22 +1018,6 @@
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)