summaryrefslogtreecommitdiff
path: root/packages/putty
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/putty
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/putty')
-rw-r--r--packages/putty/putty/lib.pro43
-rw-r--r--packages/putty/putty/plink.pro10
-rw-r--r--packages/putty/putty/pscp.pro10
-rw-r--r--packages/putty/putty/psftp.pro10
-rw-r--r--packages/putty/putty_svn.bb44
5 files changed, 0 insertions, 117 deletions
diff --git a/packages/putty/putty/lib.pro b/packages/putty/putty/lib.pro
deleted file mode 100644
index 7006228b6a..0000000000
--- a/packages/putty/putty/lib.pro
+++ /dev/null
@@ -1,43 +0,0 @@
-######################################################################
-# Automatically generated by qmake (1.06c) Wed Jun 16 23:28:56 2004
-######################################################################
-
-TEMPLATE = lib
-CONFIG = warn_on release console
-TARGET = putty
-INCLUDEPATH += . unix charset
-
-SOURCES += cmdline.c int64.c ldisc.c logging.c misc.c portfwd.c proxy.c raw.c \
- rlogin.c settings.c ssh.c sshaes.c sshblowf.c \
- sshbn.c sshcrc.c sshcrcda.c sshdes.c sshdh.c sshdss.c \
- sshmd5.c sshpubk.c sshrand.c sshrsa.c sshsh512.c sshsha.c \
- sshzlib.c telnet.c tree234.c version.c wildcard.c x11fwd.c
-
-#Charset
-SOURCES += \
- charset/localenc.c \
- charset/mimeenc.c \
- charset/sbcsdat.c \
- charset/toucs.c \
- charset/xenc.c \
- charset/fromucs.c \
- charset/macenc.c \
- charset/sbcs.c \
- charset/slookup.c \
- charset/utf8.c
-
-# Unix
-HEADERS += unix/unix.h
-SOURCES += unix/signal.c \
- unix/uxagentc.c \
- unix/uxcons.c \
- unix/uxmisc.c \
- unix/uxnet.c \
- unix/uxnoise.c \
- unix/uxproxy.c \
- unix/uxplink.c \
- unix/uxsel.c \
- unix/uxstore.c \
- unix/uxucs.c \
- unix/ux_x11.c \
- unix/xkeysym.c
diff --git a/packages/putty/putty/plink.pro b/packages/putty/putty/plink.pro
deleted file mode 100644
index 3cbf15a71d..0000000000
--- a/packages/putty/putty/plink.pro
+++ /dev/null
@@ -1,10 +0,0 @@
-TEMPLATE = app
-TARGET = plink
-CONFIG = warn_on release console
-DEPENDPATH += unix charset
-INCLUDEPATH += . unix charset
-
-SOURCES += be_all.c uxplink.c
-
-LIBS += -L. -lputty
-
diff --git a/packages/putty/putty/pscp.pro b/packages/putty/putty/pscp.pro
deleted file mode 100644
index 6e30d3ebc0..0000000000
--- a/packages/putty/putty/pscp.pro
+++ /dev/null
@@ -1,10 +0,0 @@
-TEMPLATE = app
-TARGET = pscp
-CONFIG = warn_on release console
-DEPENDPATH += unix charset
-INCLUDEPATH += . unix charset
-
-SOURCES += be_none.c scp.c sftp.c unix/uxsftp.c
-
-LIBS += -L. -lputty
-
diff --git a/packages/putty/putty/psftp.pro b/packages/putty/putty/psftp.pro
deleted file mode 100644
index 4c491bafdc..0000000000
--- a/packages/putty/putty/psftp.pro
+++ /dev/null
@@ -1,10 +0,0 @@
-TEMPLATE = app
-TARGET = psftp
-CONFIG = warn_on release console
-DEPENDPATH += unix charset
-INCLUDEPATH += . unix charset
-
-SOURCES += be_none.c psftp.c sftp.o unix/uxsftp.c
-
-LIBS += -L. -lputty
-
diff --git a/packages/putty/putty_svn.bb b/packages/putty/putty_svn.bb
deleted file mode 100644
index c96ffbb213..0000000000
--- a/packages/putty/putty_svn.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "PuTTY is a free implementation of Telnet and SSH for Win32 and Unix platforms"
-SECTION = "console/network"
-LICENSE = "MIT"
-#Remove the dash below when 0.58 changes in PV
-PV = "0.58+cvs-${SRCDATE}"
-
-SRC_URI = "svn://ixion.tartarus.org/main;module=putty \
- file://lib.pro \
- file://plink.pro \
- file://pscp.pro \
- file://psftp.pro"
-
-TARGETS = "lib plink pscp psftp"
-
-S = "${WORKDIR}/putty"
-
-inherit qmake_base
-
-do_configure() {
- for t in ${TARGETS}
- do
- install -m 0644 ${WORKDIR}/$t.pro .
- done
- cd charset && perl sbcsgen.pl
-}
-
-do_compile() {
- for t in ${TARGETS}
- do
- rm -f Makefile
- qmake -makefile -o Makefile -spec ${QMAKESPEC} $t.pro
- oe_runmake
- done
-}
-
-do_install() {
- install -d ${D}${libdir}
- oe_libinstall -so libputty ${D}${libdir}
- install -d ${D}${bindir}/
- install -m 0755 plink ${D}${bindir}/ssh
- install -m 0755 pscp ${D}${bindir}/scp
- install -m 0755 psftp ${D}${bindir}/sftp
-}
-