summaryrefslogtreecommitdiff
path: root/packages/psmisc/psmisc-21.8/libintl-link.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-06-28 09:02:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-28 09:02:47 +0000
commitea598444584f8fc9fff0ad6b482d761fcc0309c7 (patch)
tree197de3e7ddd78bc0acb2cedad5ffed3cb52a7166 /packages/psmisc/psmisc-21.8/libintl-link.patch
parent5beeda5a0119ff00a31605465613d7bd15af13ba (diff)
parenta4ec0922c99c486493b1a5bb224f315ac7ab9a26 (diff)
merge of 96fed78607f0529e7177d55147568944ff559a90
and c2ca1eca3e23b0468ffeab450e6a81d6ca829e45
Diffstat (limited to 'packages/psmisc/psmisc-21.8/libintl-link.patch')
-rw-r--r--packages/psmisc/psmisc-21.8/libintl-link.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/psmisc/psmisc-21.8/libintl-link.patch b/packages/psmisc/psmisc-21.8/libintl-link.patch
new file mode 100644
index 0000000000..d9cdd90d71
--- /dev/null
+++ b/packages/psmisc/psmisc-21.8/libintl-link.patch
@@ -0,0 +1,29 @@
+uClibc needs to link against an external libintl but it doesn't do this by
+default. The configure script correctly figures out if this is needed, but
+doesn't actually link to the libraries it decides on. This makes it link to
+them if they are needed:
+
+--- psmisc-22.2/src/Makefile.am 2006/06/28 00:14:07 1.1
++++ psmisc-22.2/src/Makefile.am 2006/06/28 00:14:24
+@@ -5,15 +5,19 @@
+
+ oldfuser_SOURCES = oldfuser.c comm.h signals.c signals.h loop.h i18n.h
+
++oldfuser_LDADD = @INTLLIBS@
++
+ fuser_SOURCES = fuser.c comm.h signals.c signals.h i18n.h fuser.h
+
++fuser_LDADD = @INTLLIBS@
++
+ killall_SOURCES = killall.c comm.h signals.c signals.h i18n.h
+
+-killall_LDADD = @SELINUX_LIB@
++killall_LDADD = @SELINUX_LIB@ @INTLLIBS@
+
+ pstree_SOURCES = pstree.c comm.h i18n.h
+
+-pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@
++pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@ @INTLLIBS@
+
+ BUILT_SOURCES = signames.h
+