summaryrefslogtreecommitdiff
path: root/packages/procps/procps-3.2.7/install.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-13 12:57:13 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-13 12:57:13 +0000
commit4fa2c89ec61664ea9842db12b1df01d879640ac1 (patch)
tree97f36a00f34f1ca365d4f14ae4aa7c0bae43aa50 /packages/procps/procps-3.2.7/install.patch
parent247469b81e9d210b2c219fc0f95d3b62249c2498 (diff)
procps: update to 3.2.7
Diffstat (limited to 'packages/procps/procps-3.2.7/install.patch')
-rw-r--r--packages/procps/procps-3.2.7/install.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/procps/procps-3.2.7/install.patch b/packages/procps/procps-3.2.7/install.patch
new file mode 100644
index 0000000000..9f1ef6915d
--- /dev/null
+++ b/packages/procps/procps-3.2.7/install.patch
@@ -0,0 +1,27 @@
+--- procps-3.2.5.virgin/Makefile 2005-01-26 05:55:26.000000000 +0100
++++ procps-3.2.5/Makefile 2005-08-03 04:55:26.346984488 +0200
+@@ -30,7 +30,10 @@
+ install := install -D --owner 0 --group 0
+
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+-lib64 := lib$(shell [ -d /lib64 ] && echo 64)
++# lib64 := lib$(shell [ -d /lib64 ] && echo 64)
++
++# Equally lame hack to work around makefile lameness when the host arch is 64bit, but the target is not.
++lib64 := lib
+
+ usr/bin := $(DESTDIR)/usr/bin/
+ bin := $(DESTDIR)/bin/
+@@ -211,10 +214,10 @@
+ ###### install
+
+ $(BINFILES) : all
+- $(install) --mode a=rx $(notdir $@) $@
++ $(install) -m 555 $(notdir $@) $@
+
+ $(MANFILES) : all
+- $(install) --mode a=r $(notdir $@) $@
++ $(install) -m 444 $(notdir $@) $@
+
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+ cd $(usr/bin) && $(ln_f) skill snice