summaryrefslogtreecommitdiff
path: root/packages/privoxy/privoxy_3.0.3.bb
diff options
context:
space:
mode:
authorBastian Ballmann <balle@chaostal.de>2006-09-26 09:57:09 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-09-26 09:57:09 +0000
commit1f3ed3b61f5a73aed5a4a995e9155dbbd631bbd2 (patch)
tree0a9367eaae1519b6fe1d7787954b4174b17c71a6 /packages/privoxy/privoxy_3.0.3.bb
parent8ff230217fc5c076bce98dd25cab91a71af77952 (diff)
privoxy: added 3.0.3 - close #1419
Diffstat (limited to 'packages/privoxy/privoxy_3.0.3.bb')
-rw-r--r--packages/privoxy/privoxy_3.0.3.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/packages/privoxy/privoxy_3.0.3.bb b/packages/privoxy/privoxy_3.0.3.bb
new file mode 100644
index 0000000000..e9bd71e45e
--- /dev/null
+++ b/packages/privoxy/privoxy_3.0.3.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "Privoxy is a web proxy with advanced filtering capabilities for protecting \
+ privacy, modifying web page content, managing cookies, controlling access, and \
+ removing ads, banners, pop-ups and other obnoxious Internet junk."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "Bastian Ballmann <balle@chaostal.de>"
+LICENSE = "GPL"
+DEPENDS = "pcre"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ijbswa/privoxy-${PV}-stable-src.tar.gz \
+ file://privoxy.conf \
+ file://privoxy.init"
+
+S = "${WORKDIR}/privoxy-${PV}-stable"
+
+inherit autotools update-rc.d
+
+LDFLAGS += "-L${STAGING_LIBDIR}"
+CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
+
+INITSCRIPT_NAME = "privoxy"
+
+do_compile() {
+ autoheader && autoconf && ./configure --host=localhost --disable-pthread
+ oe_runmake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ mkdir -p ${D}/${sbindir}
+ install -m 0755 ${S}/privoxy ${D}/${sbindir}
+
+ # Documentation
+ mkdir -p ${D}/${docdir}
+ install -m 0755 -d ${S}/doc ${D}/${docdir}
+
+ # Install man page
+ mkdir -p ${D}/${mandir}
+ install -m 0755 ${S}/privoxy.1 ${D}/${mandir}
+}
+
+
+do_install_append() {
+ # Install config files
+ install -d ${D}${sysconfdir}/privoxy/templates
+ install ${WORKDIR}/privoxy.conf ${D}${sysconfdir}/privoxy/config
+ install ${S}/templates/* ${D}${sysconfdir}/privoxy/templates/
+ install ${S}/default.action ${D}${sysconfdir}/privoxy/
+ install ${S}/default.filter ${D}${sysconfdir}/privoxy/
+ install ${S}/standard.action ${D}${sysconfdir}/privoxy/
+ install ${S}/trust ${D}${sysconfdir}/privoxy/
+ install ${S}/user.action ${D}${sysconfdir}/privoxy/
+
+ # Install init script
+ install -d ${D}${sysconfdir}/init.d
+ install ${WORKDIR}/privoxy.init ${D}${sysconfdir}/init.d/privoxy
+}
+
+# Add user and groups
+pkg_postinst() {
+ grep -q privoxy: /etc/group || addgroup privoxy
+ grep -q privoxy: /etc/passwd || adduser --disabled-password --home=/etc/privoxy \
+ --ingroup privoxy -g "Privoxy" privoxy
+}