summaryrefslogtreecommitdiff
path: root/packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-04-01 08:04:29 +0000
committerKoen Kooi <koen@openembedded.org>2007-04-01 08:04:29 +0000
commit3129c86f276aa902644bd711c001ccfb444fb8e3 (patch)
tree139ce8746851f1f3edd9a3580aca44cc0fa620aa /packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
parenta766c449f0c96073657a3eadb7c47a4fef7bfa79 (diff)
prismstumbler: fix PV
Diffstat (limited to 'packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb')
-rw-r--r--packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb b/packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
new file mode 100644
index 0000000000..44401df7dd
--- /dev/null
+++ b/packages/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
@@ -0,0 +1,40 @@
+SECTION = "x11/network"
+PR = "r0"
+
+PACKAGES = "prismstumbler prismstumbler-frontend prismstumbler-doc"
+DESCRIPTION = "Prismstumbler wireless LAN scanner"
+DESCRIPTION_prismstumbler-frontend = "Prismstumbler wireless LAN scanner GTK frontend"
+LICENSE = "GPL"
+DEPENDS = "libpcap gtk+ wireless-tools sqlite zlib dbus-glib gpsd"
+RDEPENDS = "wireless-tools"
+RRECOMMENDS = "gpsd"
+
+SRC_URI = "http://projects.linuxtogo.org/frs/download.php/14/${PN}-0.7.4pre1.tar.gz"
+
+S = "${WORKDIR}/${PN}-0.7.4pre1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-libgps=${STAGING_DIR}/${HOST_SYS} \
+ --with-libpcap=${STAGING_DIR}/${HOST_SYS} \
+ --with-sqlite-includes=${STAGING_INCDIR} \
+ --with-sqlite-libs=${STAGING_LIBDIR} \
+ --without-athena --enable-dbus"
+
+CFLAGS =+ "-I${S}/include"
+LDFLAGS += "-lz"
+
+FILES_${PN} = "${bindir}/prismstumbler"
+
+FILES_prismstumbler-frontend = "${bindir}/psfront ${bindir}/pst \
+ ${datadir}/applications \
+ ${datadir}/pixmaps ${docdir}/prismstumbler/help.txt \
+ ${sysconfdir}"
+RDEPENDS_prismstumbler-frontend = "${PN}"
+
+
+do_install_append() {
+ chmod a+s ${D}${bindir}/prismstumbler
+}