summaryrefslogtreecommitdiff
path: root/packages/postgresql/postgresql_8.2.4.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-12 13:21:27 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-12 13:21:27 +0000
commit254997957ebd4c77f0a489e4259d5b13272dc18a (patch)
tree78197b074570fccc9ea8ee9eb077ac2c772bebce /packages/postgresql/postgresql_8.2.4.bb
parenta5b9c0a3c9a3d134d89d7c3f268b4aaab2f213f5 (diff)
parent6bb2ac73d2204983830f51a73c7dc686860faf04 (diff)
merge of 'c46f8208c373d5560ddd45271e743c4c230bd2cd'
and 'f261cf941f77cd9c8da55b02b29790fe6ade119d'
Diffstat (limited to 'packages/postgresql/postgresql_8.2.4.bb')
-rw-r--r--packages/postgresql/postgresql_8.2.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/postgresql/postgresql_8.2.4.bb b/packages/postgresql/postgresql_8.2.4.bb
new file mode 100644
index 0000000000..3f65a4fd0d
--- /dev/null
+++ b/packages/postgresql/postgresql_8.2.4.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "PostgreSQL is a powerful, open source relational database system."
+HOMEPAGE = "http://www.postgresql.com"
+LICENSE = "BSD"
+DEPENDS = "zlib readline"
+
+#WARNING: this recipe assumes you have the timezone compiler present in /usr/sbin/zic
+
+SRC_URI = "ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v${PV}/${P}.tar.bz2 \
+ file://no-ecpg-test.patch;patch=1"
+
+
+inherit autotools pkgconfig
+
+FILES_${PN}-doc += "${prefix}/doc/"
+
+do_compile_append() {
+cp /usr/sbin/zic ${S}/src/timezone/
+}
+
+DEFAULT_PREFERENCE = "-1"