summaryrefslogtreecommitdiff
path: root/packages/pidgin
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/pidgin
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/pidgin')
-rw-r--r--packages/pidgin/pidgin.inc83
-rw-r--r--packages/pidgin/pidgin/gconf-no-errors.patch12
-rw-r--r--packages/pidgin/pidgin/pidgin-cross-python.patch16
-rw-r--r--packages/pidgin/pidgin/pidgin.desktop-set-icon.patch11
-rw-r--r--packages/pidgin/pidgin/purple-OE-branding-25.patch16
-rw-r--r--packages/pidgin/pidgin/purple-OE-branding.patch14
-rw-r--r--packages/pidgin/pidgin/sanitize-configure.ac.patch33
-rw-r--r--packages/pidgin/pidgin_2.5.3.bb17
8 files changed, 0 insertions, 202 deletions
diff --git a/packages/pidgin/pidgin.inc b/packages/pidgin/pidgin.inc
deleted file mode 100644
index 913cf1c248..0000000000
--- a/packages/pidgin/pidgin.inc
+++ /dev/null
@@ -1,83 +0,0 @@
-DESCRIPTION = "multi-protocol instant messaging client"
-SECTION = "x11/network"
-LICENSE = "GPL"
-DEPENDS = "python startup-notification avahi gtk+ ncurses gnutls virtual/libintl gstreamer dbus"
-
-inherit autotools gettext pkgconfig gconf
-
-EXTRA_OECONF = " \
- --disable-audio \
- --disable-perl \
- --disable-tcl \
- --disable-deprecated \
- --disable-gevolution \
- --x-includes=${STAGING_INCDIR} \
- --x-libraries=${STAGING_LIBDIR} \
- --enable-gnutls=yes \
- --with-ncurses-headers=${STAGING_INCDIR} \
- --with-gnutls-includes=${STAGING_INCDIR} \
- --with-gnutls-libs=${STAGING_LIBDIR} \
- "
-
-OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
-OE_LT_RPATH_ALLOW[export]="1"
-
-PACKAGES =+ "libpurple-dbg libpurple-dev libpurple libgnt-dbg libgnt libgnt-dev finch-dbg finch finch-dev ${PN}-data"
-
-LEAD_SONAME = "libpurple.so.0"
-FILES_libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
-FILES_libpurple-dev = "${libdir}/libpurple*.la \
- ${libdir}/libpurple*.so \
- ${libdir}/purple-2/*.la \
- ${libdir}/purple-2/libjabber.so \
- ${libdir}/purple-2/liboscar.so \
- ${datadir}/aclocal"
-FILES_libpurple-dbg += "${libdir}/.debug/libpurple* \
- ${libdir}/purple-2/.debug"
-FILES_libgnt = "${libdir}/libgnt.so.* ${libdir}/gnt/*.so"
-FILES_libgnt-dev = "${libdir}/gnt/*.la"
-FILES_libgnt-dbg = "${libdir}/gnt/.debug \
-FILES_finch = "${bindir}/finch"
-FILES_finch-dev = "${libdir}/finch/*.la"
-FILES_finch-dbg = "${bindir}/.debug/finch \
- ${libdir}/finch/.debug"
-
-FILES_${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
- ${datadir}/applications"
-RRECOMMENDS_${PN} = "${PN}-data libpurple-plugin-ssl-gnutls libpurple-protocol-irc libpurple-protocol-xmpp"
-
-FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons"
-FILES_${PN}-dev += "${libdir}/${PN}/*.la"
-
-PACKAGES_DYNAMIC = "libpurple-protocol-* libpurple-plugin-* pidgin-plugin-* finch-plugin-*"
-
-python populate_packages_prepend () {
- root = bb.data.expand('${libdir}/pidgin', d)
- purple = bb.data.expand('${libdir}/purple-2', d)
- finch = bb.data.expand('${libdir}/finch', d)
-
- do_split_packages(d, root, '^([^l][^i][^b].*)\.so$',
- output_pattern='pidgin-plugin-%s',
- description='Pidgin plugin %s',
- prepend=True, extra_depends='')
-
- do_split_packages(d, purple, '^lib(.*)\.so$',
- output_pattern='libpurple-protocol-%s',
- description='Libpurple protocol plugin for %s',
- prepend=True, extra_depends='')
-
- do_split_packages(d, purple, '^(ssl-.*)\.so$',
- output_pattern='libpurple-plugin-%s',
- description='libpurple plugin %s',
- prepend=True, extra_depends='libpurple-plugin-ssl')
-
- do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$',
- output_pattern='libpurple-plugin-%s',
- description='libpurple plugin %s',
- prepend=True, extra_depends='')
-
- do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$',
- output_pattern='finch-plugin-%s',
- description='Finch plugin %s',
- prepend=True, extra_depends='')
-}
diff --git a/packages/pidgin/pidgin/gconf-no-errors.patch b/packages/pidgin/pidgin/gconf-no-errors.patch
deleted file mode 100644
index 9a95175ac9..0000000000
--- a/packages/pidgin/pidgin/gconf-no-errors.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- /tmp/Makefile.am 2007-05-08 18:39:49.000000000 +0200
-+++ pidgin-2.0.0/libpurple/gconf/Makefile.am 2007-05-08 18:40:13.755251000 +0200
-@@ -8,8 +8,7 @@
-
- if GCONF_SCHEMAS_INSTALL
- install-data-local:
-- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 | \
-- grep -v "^WARNING: failed to install schema" | grep -v "^Attached schema" 1>&2
-+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1
- else
- install-data-local:
- endif
diff --git a/packages/pidgin/pidgin/pidgin-cross-python.patch b/packages/pidgin/pidgin/pidgin-cross-python.patch
deleted file mode 100644
index ca88502b67..0000000000
--- a/packages/pidgin/pidgin/pidgin-cross-python.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: pidgin-2.4.3/configure.ac
-===================================================================
---- pidgin-2.4.3.orig/configure.ac 2008-07-14 13:13:16.000000000 +0000
-+++ pidgin-2.4.3/configure.ac 2008-07-14 13:34:12.000000000 +0000
-@@ -1350,8 +1350,9 @@
- AC_CHECK_LIB(pthread, pthread_create, )
- AC_CHECK_LIB(util, openpty, )
- AC_CHECK_LIB(db, dbopen, )
-- PY_LIBS="-lpython$PY_VERSION -L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
-- PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
-+ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
-+ PY_LIBS="-lpython$PY_VERSION -L$PKG_CONFIG_SYSROOT_DIR/usr/lib/python$PY_VERSION/config"
-+ PY_CFLAGS="-I$PKG_CONFIG_SYSROOT_DIR/usr/include/python$PY_VERSION"
- AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
- AC_MSG_RESULT(ok)
- else
diff --git a/packages/pidgin/pidgin/pidgin.desktop-set-icon.patch b/packages/pidgin/pidgin/pidgin.desktop-set-icon.patch
deleted file mode 100644
index 05f76895ba..0000000000
--- a/packages/pidgin/pidgin/pidgin.desktop-set-icon.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pidgin-2.0.1/pidgin.desktop.in.orig 2007-06-20 23:50:44.000000000 +0000
-+++ pidgin-2.0.1/pidgin.desktop.in 2007-06-20 23:51:05.000000000 +0000
-@@ -4,7 +4,7 @@
- _GenericName=Internet Messenger
- _Comment=Send instant messages over multiple protocols
- Exec=pidgin
--Icon=pidgin
-+Icon=/usr/share/icons/hicolor/48x48/apps/pidgin.png
- StartupNotify=true
- Terminal=false
- Type=Application
diff --git a/packages/pidgin/pidgin/purple-OE-branding-25.patch b/packages/pidgin/pidgin/purple-OE-branding-25.patch
deleted file mode 100644
index 293ef709d1..0000000000
--- a/packages/pidgin/pidgin/purple-OE-branding-25.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: pidgin-2.5.0/libpurple/protocols/irc/irc.h
-===================================================================
---- pidgin-2.5.0.orig/libpurple/protocols/irc/irc.h 2008-08-19 01:53:38.000000000 +0000
-+++ pidgin-2.5.0/libpurple/protocols/irc/irc.h 2008-08-27 11:15:58.000000000 +0000
-@@ -36,9 +36,9 @@
-
- #define IRC_DEFAULT_CHARSET "UTF-8"
- #define IRC_DEFAULT_AUTODETECT FALSE
--#define IRC_DEFAULT_ALIAS "purple"
-+#define IRC_DEFAULT_ALIAS "OE-user"
-
--#define IRC_DEFAULT_QUIT "Leaving."
-+#define IRC_DEFAULT_QUIT "Powered by OE: www.openembedded.org"
-
- #define IRC_INITIAL_BUFSIZE 1024
-
diff --git a/packages/pidgin/pidgin/purple-OE-branding.patch b/packages/pidgin/pidgin/purple-OE-branding.patch
deleted file mode 100644
index 99c61375ce..0000000000
--- a/packages/pidgin/pidgin/purple-OE-branding.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- /tmp/irc.h 2007-08-04 20:27:10.000000000 +0200
-+++ pidgin-2.1.0/libpurple/protocols/irc/irc.h 2007-08-04 20:28:15.318400000 +0200
-@@ -35,9 +35,9 @@
- #define IRC_DEFAULT_SSL_PORT 994
-
- #define IRC_DEFAULT_CHARSET "UTF-8"
--#define IRC_DEFAULT_ALIAS "purple"
-+#define IRC_DEFAULT_ALIAS "OE-user"
-
--#define IRC_DEFAULT_QUIT "Leaving."
-+#define IRC_DEFAULT_QUIT "Powered by OE: www.openembedded.org"
-
- #define IRC_INITIAL_BUFSIZE 1024
-
diff --git a/packages/pidgin/pidgin/sanitize-configure.ac.patch b/packages/pidgin/pidgin/sanitize-configure.ac.patch
deleted file mode 100644
index a77d64f40b..0000000000
--- a/packages/pidgin/pidgin/sanitize-configure.ac.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- /tmp/configure.ac 2007-05-08 17:29:02.000000000 +0200
-+++ pidgin-2.0.0/configure.ac 2007-05-08 17:30:30.325251000 +0200
-@@ -472,7 +472,7 @@
- if test "x$enable_consoleui" = "xyes"; then
- dnl # Some distros put the headers in ncursesw/, some don't
- found_ncurses_h=no
-- for location in $ac_ncurses_includes $NCURSES_HEADERS /usr/include/ncursesw /usr/include
-+ for location in $ac_ncurses_includes $NCURSES_HEADERS
- do
- f="$location/ncurses.h"
- AC_CHECK_HEADER($f,[
-@@ -1860,10 +1860,6 @@
- KRB4_CFLAGS="$KRB4_CFLAGS -I${kerberos}/include/kerberosIV"
- fi
- KRB4_LDFLAGS="-L${kerberos}/lib"
-- elif test -d /usr/local/include/kerberosIV ; then
-- KRB4_CFLAGS="-I/usr/local/include/kerberosIV"
-- elif test -d /usr/include/kerberosIV ; then
-- KRB4_CFLAGS="-I/usr/include/kerberosIV"
- fi
- AC_DEFINE(ZEPHYR_USES_KERBEROS, 1, [Define if kerberos should be used in Zephyr.])
-
-@@ -1896,10 +1892,6 @@
- ZEPHYR_LDFLAGS="-L${zephyr}/lib"
- elif test -d /usr/athena/include/zephyr ; then
- ZEPHYR_CFLAGS="-I/usr/athena/include"
-- elif test -d /usr/include/zephyr ; then
-- ZEPHYR_CFLAGS="-I/usr/include"
-- elif test -d /usr/local/include/zephyr ; then
-- ZEPHYR_CFLAGS="-I/usr/local/include"
- fi
- AC_DEFINE(LIBZEPHYR_EXT, 1 , [Define if external libzephyr should be used.])
- AM_CONDITIONAL(EXTERNAL_LIBZEPHYR, test "x$zephyr" != "xno")
diff --git a/packages/pidgin/pidgin_2.5.3.bb b/packages/pidgin/pidgin_2.5.3.bb
deleted file mode 100644
index 17d0270456..0000000000
--- a/packages/pidgin/pidgin_2.5.3.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-require pidgin.inc
-
-SRC_URI = "\
- ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
- file://sanitize-configure.ac.patch;patch=1 \
- file://gconf-no-errors.patch;patch=1 \
- file://pidgin.desktop-set-icon.patch;patch=1 \
- file://purple-OE-branding-25.patch;patch=1 \
- file://pidgin-cross-python.patch;patch=1 \
-"
-
-EXTRA_OECONF += "\
- --disable-gtkspell \
- --disable-meanwhile \
- --disable-nm \
- --disable-screensaver \
-"