summaryrefslogtreecommitdiff
path: root/packages/piccontrol/piccontrol_0.4.bb
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-17 18:04:39 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-17 18:04:39 +0000
commitdc10abcda446ad5b1628134797eddedea814f5e3 (patch)
treefd186fc03f18bba35c673527922608ef5cded413 /packages/piccontrol/piccontrol_0.4.bb
parent33172ddea53386be40b4177fce3dcdee4456e209 (diff)
piccontrol: Add piccontrol, missing dep of ts109 and ts209 (tsx09) machines - led/fan/etc control
Diffstat (limited to 'packages/piccontrol/piccontrol_0.4.bb')
-rw-r--r--packages/piccontrol/piccontrol_0.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/piccontrol/piccontrol_0.4.bb b/packages/piccontrol/piccontrol_0.4.bb
new file mode 100644
index 0000000000..7ec7e4c7d9
--- /dev/null
+++ b/packages/piccontrol/piccontrol_0.4.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Microcontroller utility for ARM turbostations by Byron Bradley"
+SECTION = "console/network"
+DEPENDS = "lua5.1"
+FILE_PR = "r0"
+LICENSE = "GPL"
+
+COMPATIBLE_MACHINE = "tsx09"
+
+LDFLAGS += " ${STAGING_LIBDIR}/liblua5.1.a -lpthread -lm -ldl "
+CFLAGS += " -I${STAGING_INCDIR}/lua5.1 "
+
+S = "${WORKDIR}/qcontrol-${PV}"
+
+SRC_URI = "http://byronbradley.co.uk/piccontrol/qcontrol-0.4.tar.gz \
+ file://luafix-0.4.patch;patch=0 \
+ file://configlocation.patch;patch=1 \
+ file://piccontrol-0.4.conf"
+
+do_install() {
+ install -d ${D}${sbindir} \
+ ${D}${sysconfdir}
+ install -c -m 755 ${S}/piccontrol ${D}${sbindir}/piccontrol
+ install -m 0644 ${WORKDIR}/piccontrol-0.4.conf ${D}${sysconfdir}/piccontrol.conf
+}
+