summaryrefslogtreecommitdiff
path: root/packages/perl/perl_5.8.7.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-04-05 09:02:55 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-04-05 09:02:55 +0000
commit4df8a4c61a36dee1830e1e52980e100c8f8cd5a1 (patch)
tree07822969fa0915be192b319ec5c30e190a782d72 /packages/perl/perl_5.8.7.bb
parentb19fbe04169b2eda4d8f833fbc548b183e4e9442 (diff)
parentb96de293f83c5860731e5a63ef27b1af2921a23c (diff)
merge of '93691535aba89a9ed8c657fdc80e62bf1e46e93d'
and 'dfdda7c548b2b8c023a5e9015f79c6f450c91fa3'
Diffstat (limited to 'packages/perl/perl_5.8.7.bb')
-rw-r--r--packages/perl/perl_5.8.7.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/packages/perl/perl_5.8.7.bb b/packages/perl/perl_5.8.7.bb
index 12aec88a02..874c95a79c 100644
--- a/packages/perl/perl_5.8.7.bb
+++ b/packages/perl/perl_5.8.7.bb
@@ -7,6 +7,7 @@ require perl.inc
SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-arm-linux \
file://config.sh-powerpc-linux \
+ file://config.sh-mipsel-linux \
file://config.sh-i386-linux \
file://config.sh-i486-linux \
file://config.sh-i586-linux \
@@ -15,14 +16,13 @@ SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-sh3-linux \
file://config.sh-sh4-linux"
-# Patches for sh3/sh4, use gcc to link and override generaet.sh to
-# use PIC mode for compiling shared library objects.
-SRC_URI_append_sh4 += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_sh4 += "file://makefile-usegcc-to-link.patch;patch=1"
-SRC_URI_append_sh3 += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_sh3 += "file://makefile-usegcc-to-link.patch;patch=1"
-SRC_URI_append_powerpc += "file://override-generate-sh.patch;patch=1"
-SRC_URI_append_powerpc += "file://makefile-usegcc-to-link.patch;patch=1"
+# Use gcc to link and use PIC mode for compiling shared libs
+GCCLINK_SRC = "file://override-generate-sh.patch;patch=1 \
+ file://makefile-usegcc-to-link.patch;patch=1"
+
+SRC_URI_append_sh4 += " ${GCCLINK_SRC}"
+SRC_URI_append_sh3 += " ${GCCLINK_SRC}"
+SRC_URI_append_powerpc += " ${GCCLINK_SRC}"
PARALLEL_MAKE = ""