summaryrefslogtreecommitdiff
path: root/packages/pciutils/pciutils_2.2.4.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-10-31 11:25:13 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-31 11:25:13 +0000
commit88583bf8b912cc8d2f8575cd5bbcc61138efad7c (patch)
tree8b8f3cb3d64bde55072c4f4011277f122c6b5f2d /packages/pciutils/pciutils_2.2.4.bb
parent545044bfbd7135fb30d507e1cf77554ee0bc8061 (diff)
pciutils: added 2.2.4
Diffstat (limited to 'packages/pciutils/pciutils_2.2.4.bb')
-rw-r--r--packages/pciutils/pciutils_2.2.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/pciutils/pciutils_2.2.4.bb b/packages/pciutils/pciutils_2.2.4.bb
new file mode 100644
index 0000000000..ce683a152a
--- /dev/null
+++ b/packages/pciutils/pciutils_2.2.4.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
+to PCI bus configuration space and several utilities based on this library.'
+DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
+SECTION = "console/utils"
+HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
+LICENSE = "GPLv2"
+DEPENDS = "zlib"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://pcimodules-pciutils.diff;patch=1"
+
+PARALLEL_MAKE = ""
+
+do_configure () {
+ (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
+}
+
+export PREFIX = "${D}${prefix}"
+export SBINDIR = "${D}${sbindir}"
+export SHAREDIR = "${D}${datadir}"
+export MANDIR = "${D}${mandir}"
+
+LDFLAGS += "-lz"
+
+do_install () {
+ oe_runmake install
+}
+do_install_append () {
+ install -d ${D}/${prefix}/share
+ install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
+}
+
+PACKAGES =+ "pciutils-ids"
+FILES_pciutils-ids="${prefix}/share/pci.ids"