summaryrefslogtreecommitdiff
path: root/packages/oprofile/oprofile_0.9.4.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-08-08 13:43:45 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-08-08 13:43:45 +0000
commit7368c24df7043ab141500e2dc7a4df8f43eabef6 (patch)
treefd0a7b527abbb8a6c1105f9decb60858318736b9 /packages/oprofile/oprofile_0.9.4.bb
parent4a95b1479e1c44da2a37d0207724842e30564a05 (diff)
oprofile 0.9.3: Fixed armv7a patch to actually distribute armv7 event files.
oprofile 0.9.4: New recipe.
Diffstat (limited to 'packages/oprofile/oprofile_0.9.4.bb')
-rw-r--r--packages/oprofile/oprofile_0.9.4.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/oprofile/oprofile_0.9.4.bb b/packages/oprofile/oprofile_0.9.4.bb
new file mode 100644
index 0000000000..f8fb744fcc
--- /dev/null
+++ b/packages/oprofile/oprofile_0.9.4.bb
@@ -0,0 +1,40 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+DEPENDS = "popt binutils"
+RDEPENDS = "binutils-symlinks"
+RRECOMMENDS = "kernel-vmlinux"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+ file://opjitconv-execvp-fix.diff;patch=1 \
+ file://0.9.4-armv7a.diff;patch=1 \
+ file://acinclude.m4 \
+ "
+
+inherit autotools
+
+EXTRA_OECONF = " \
+ --with-kernel-support \
+ --without-x \
+ "
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+
+do_stage () {
+ # As of 0.9.4 there is a libopagent library to compile and link against.
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dev ${PN}-doc ${PN}-dbg ${PN}"
+
+FILES_${PN}-dev += "\
+ ${libdir}/oprofile/lib*.so \
+ ${libdir}/oprofile/lib*.a \
+ ${libdir}/oprofile/lib*.la \
+"