summaryrefslogtreecommitdiff
path: root/packages/oprofile/oprofile_0.9.3.bb
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-08-08 13:39:14 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-08-08 13:39:14 +0000
commit331a5730ca69b286aec996692a6d8843d3ee4e93 (patch)
tree23dbaac6273acf061761c8bdf7d87bab10c4a0c2 /packages/oprofile/oprofile_0.9.3.bb
parent213b12efcd44463dbdd77f2f351d0d7e7edfd314 (diff)
oprofile: add 0.9.3, update cvs, drop 0.9.1 left-overs
- the no_arm_mapping_syms and opcontrol_bashisms patches are applied upstream
Diffstat (limited to 'packages/oprofile/oprofile_0.9.3.bb')
-rw-r--r--packages/oprofile/oprofile_0.9.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/oprofile/oprofile_0.9.3.bb b/packages/oprofile/oprofile_0.9.3.bb
new file mode 100644
index 0000000000..d758b97549
--- /dev/null
+++ b/packages/oprofile/oprofile_0.9.3.bb
@@ -0,0 +1,38 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+DEPENDS = "popt binutils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+ file://acinclude.m4"
+S = "${WORKDIR}/oprofile-${PV}"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+ --without-x \
+ --disable-werror "
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+# Available config options
+# --enable-abi enable abi portability code (default is disabled)
+# --enable-pch enable precompiled header (default is disabled)
+# --enable-gcov enable option for gcov coverage testing (default is disabled)
+# --disable-werror disable -Werror flag (default is enabled for non-release)
+# --disable-optimization disable optimization flags (default is enabled)
+# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
+# --with-linux=dir Path to Linux source tree
+# --with-module-dir=dir Path to module installation directory
+# --with-extra-includes=DIR add extra include paths
+# --with-extra-libs=DIR add extra library paths
+# --with-x use the X Window System
+# --with-qt-dir where the root of Qt is installed
+# --with-qt-includes where the Qt includes are.
+# --with-qt-libraries where the Qt library is installed.