summaryrefslogtreecommitdiff
path: root/packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-01-23 05:01:14 +0000
committerRod Whitby <rod@whitby.id.au>2007-01-23 05:01:14 +0000
commit73ec7248a6afa80e2db3c4560ae86d85464a71c8 (patch)
tree36c724e868ababbbabdf12bddc768e6b25b7465b /packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch
parenta26989c694c564990b73d96270654f44c2fc8d3c (diff)
nslu2-kernel: Moved to obsolete - replaced long ago by ixp4xx-kernel.
Diffstat (limited to 'packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch')
-rw-r--r--packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch b/packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch
new file mode 100644
index 0000000000..913f44e2ae
--- /dev/null
+++ b/packages/obsolete/nslu2/nslu2-kernel/2.6/x1205-rtc.patch
@@ -0,0 +1,38 @@
+--- linux-2.6.11/.pc/2.6.patch/drivers/i2c/chips/Kconfig 2005-06-17 17:51:28.635578329 -0700
++++ linux-2.6.11/drivers/i2c/chips/Kconfig 2005-06-17 17:51:32.565982545 -0700
+@@ -430,6 +430,15 @@
+
+ This driver can also be built as a module. If so, the module
+ will be called isp1301_omap.
++config SENSORS_X1205
++ tristate "Xicor X1205 RTC chip"
++ depends on I2C && EXPERIMENTAL
++ select I2C_SENSOR
++ help
++ If you say yes here you get support for the Xicor x1205 RTC chip.
++
++ This driver can also be built as a module. If so, the module
++ will be called x1205-rtc
+
+ config SENSORS_M41T00
+ tristate "ST M41T00 RTC chip"
+--- linux-2.6.11/.pc/2.6.patch/drivers/i2c/chips/Makefile 2005-06-17 17:51:28.636578177 -0700
++++ linux-2.6.11/drivers/i2c/chips/Makefile 2005-06-17 17:51:32.566982394 -0700
+@@ -41,6 +41,7 @@
+ obj-$(CONFIG_SENSORS_VIA686A) += via686a.o
+ obj-$(CONFIG_SENSORS_W83L785TS) += w83l785ts.o
+ obj-$(CONFIG_ISP1301_OMAP) += isp1301_omap.o
++obj-$(CONFIG_SENSORS_X1205) += x1205-rtc.o
+
+ ifeq ($(CONFIG_I2C_DEBUG_CHIP),y)
+ EXTRA_CFLAGS += -DDEBUG
+--- linux-2.6.11/.pc/2.6.patch/include/linux/i2c-id.h 2005-06-17 17:51:31.358165630 -0700
++++ linux-2.6.11/include/linux/i2c-id.h 2005-06-17 17:51:32.569981939 -0700
+@@ -108,6 +108,7 @@
+ #define I2C_DRIVERID_TDA7313 62 /* TDA7313 audio processor */
+ #define I2C_DRIVERID_MAX6900 63 /* MAX6900 real-time clock */
+ #define I2C_DRIVERID_SAA7114H 64 /* video decoder */
++#define I2C_DRIVERID_X1205 0xF0
+
+
+ #define I2C_DRIVERID_EXP0 0xF0 /* experimental use id's */